
R is For All – Part 1: R Commander
Alongside R Swirl, R Commander as ‘Quick Start’: a

code-generating Graphical User Interface to serve as 
‘gateway’ to sooner use of R in your Data Analyses

Emily Leary & Ken Wilkins
2025-07-31

NIDDK Biostats Seminar Series

Please note: if any PDF hyperlinks within a multi-layered slide series appear not to work, please browse to _final_ (full) slides in that series to use the hyperlinks

https://www.niddk.nih.gov/news/meetings-workshops/2025/r-is-for-all
https://bioinformatics.ccr.cancer.gov/btep/?s=niddk
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Other helpful 
resources / 

seminars 
within NIH:

R is For All
Learning Objectives:
Be able to identify, load, & use R resources/packages based upon needs & 
experience level with R.  
1. For beginners, know how to load R Commander, import data, and
navigate the GUI.  

2. For those interested in learning more about coding/functions, how to use R Swirl to learn
foundations for functions and coding higher level operations (loops, combining functions, and
building new functions).

3. For regular users of R, how to use tidyverse for data manipulation, organization, and
preparation for analysis.

4. For those using R for research work, how to utilize R Markdown for appropriate and
thorough project documentation and management.

NOTE: we only provide a ‘whistlestop’/‘whirlwind’ tour – seek 
other introductions for a fuller picture!

https://bioinformatics.ccr.cancer.gov/btep/classes/niddk-biostats-seminar-series-
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Fu n ct ion a I i ty 

Programming language 

Statistical computing, analysis 

Command-line 

Core statistical analysis & graphing 
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RStudio 

' R Commander 

File Edit Data Statistics Graphs Models Distributions 

� Edit data set 

'Low-code' entry way into R Workflow Development 

Enhancing use of R through menu-driven use, plugins 
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R Commander: a less-steep learning curve for R,
distinct interface from the widely-known Rstudio’

Things to Consider

Base R R Commander or ‘Rcmdr’

Nature Programming language ‘Low-code’ entry way into R Workflow Development

Usage Statistical computing, analysis Enhancing use of R through menu-driven use, plugins

User Interface Command-line GUI with additional plugins to implement extensions 

Functionality Core statistical analysis & graphing Code generation per menu-chosen steps, customizable

This is where (in Rgui) 
everything is viewed

This remains “behind 
the scenes” of Rcmdr;

TILL you need a GRAPH!

This becomes 
where (in Rcmdr) 
everything gets 

done 



R is For All, Part 1: R Commander to lower learning curves, via:
• Loading Rcmdr, Orientation to its GUI Window’s panels/menus
• Importing Data, setting an Active Dataset, single dataset exploration
• Navigating menus & generating re-usable code: exploring Active data

• Take Home Objective: For beginners, know how to load R
Commander, import data, and navigate the GUI.

NIDDK Biostats Seminar Series Speaker 
Today, 2025-07-31 

Ken Wilkins: Mathematical Statistician, Biostatistics Program Office
Office of the Director, NIDDK

https://bioinformatics.ccr.cancer.gov/btep/classes/principles-of-data-collection-and-management
https://bioinformatics.ccr.cancer.gov/btep/classes/principles-of-data-collection-and-management
https://bioinformatics.ccr.cancer.gov/btep/classes/principles-of-data-collection-and-management


R Commander: online resources to get started 
NB: NOT a hands-on session, only 'try as you listen' later in webinar 

• Outside-of-webinar resources for getting started on yr own

• 
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R Commander: online resources to get started 
NB: NOT a hands-on session, only 'try as you listen' later in webinar 

• Outside-of-webinar resources for getting started on yr own
• Ones on 'working within Rstudio': these date from an era when you wouldn't get below l error

• Under 10 minutes: An Introduction to R Commander (Rcmdr): Basic Statistics GUI for R-YouTube

• Under 1 hour: (also R GUI) https://www.youtube.com/watch?v=7 A0VPxwjh3w

• OTHERS to be shared under our NIH-wide-accessible SharePoint folder

R Session Aborted 

R encountered a fatal error. 

The session was terminated. 

Start New Session 



• NB: NOT a hands-on session, only ‘try as you listen’ later in webinar

• Outside-of-webinar resources for getting started on yr own
• Ones on ‘Working within Rstudio’: these date from an era when you wouldn’t get below \ error

• Under 10 minutes: An Introduction to R Commander (Rcmdr): Basic Statistics GUI for R – YouTube

• Under 1 hour: (also R GUI) https://www.youtube.com/watch?v=7A0VPxwjh3w
• OTHERS to be shared under our NIH-wide-accessible SharePoint folder

• Working within R- GUI alone for our current session: sidestep issues
• Installation will depend on your operating system(s):

• Windows – use Single Document Interface (SDI) option for best ‘behavior’
• Mac – some care needed with regard to the Graphical-display device
• Linux/Unix – may be rare, yet the “R Commander GUI” should work as well

• Why ‘jump through hoops’ just to install a running version?
• PAYS OFF by the TIME SAVED on getting started importing & viewing data
• REAPS BIGGER DIVIDENDS as you can quickly explore data AND save associated code: REPRODUCIBILTY

• How R Commander provides a less-steep learning curve: helps facilitate data analysis overall.

R Commander: online resources to get started

https://www.youtube.com/watch?v=1k6uYhNuYs4
https://www.youtube.com/watch?v=7A0VPxwjh3w


After starting the 
• Set CRAN mirro 

File Edit View Misc Packages Windows Help 

�� !§]Ii]� Load package .. . 

R RConsole 

R version ,;.;.o 
Copyright (C) 201 
Platform: x86_6i· 

Sd CRAN mirror ... 

Select repositories ... 

Install package(s) .. . 

Update packages .. . 

Install package(s) from local files ... 

CompuL.ing 

R is free software and comes with ABSOLUTELY NO WARRANTY. 

You are welco�e to rea1,cr1bute lt under certain condltlon,. 
Type 'license{)• or 'licence()• for distribution details. 

Natural language support buc running in an English locale 

R 1s a collaborative project with many contributors. 

Type 'contributors()' for more inforrr�tion and 

'c itation()' on how to cite R or R paeka9es in publications. 

Type 'demo()' for some demos, 'help()' for on-line help, or 
'help.start()' tor an ii'IML browser in'tertace 'tO help. 

• 

R Graphical User Interface (GU I), see Packages 

r then 

• 

Se<ute CRAN nwrott 
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' .. install 'Rcmdr': select menu 'Packages> Install 
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.--------------------------

<it RGui 

File Edit View Mjsc Pacbges Windows Help 

R RConsole 

R version 1.1:.0 
Copyrioht (C) 20: 
Plactorm: xS6_M.• 

Load package ... 

Set CRAN mirr01 .. . 

Sele-ct repositories .. . 

lnst6U p•ckagc{s) .. . 

Update packages .. . 

Inst.ti! p•ckagc{s) from local files ... 

R is free software and comes with ABSOLUTELY NO WAARA..'-ITY. 
You are welcome to redistribute it under certain conditions. 
Type 'license()' or 'licence(}' for distribution dctail3. 

Natural lanqua9e support buc runninq in an tnqlish locale 

R is a  collaborative pro)ecc wich �Any concr1bucors. 
Type 'concributors()' for more informacion and 
'citation(}' on how to cite R or R packaQe3 in publication3. 

Type 'dell'IO()' for some demos, 'help()' for on-line help, or 
'help.start{)' for an HTML browser interface co help. 
Type 'q()' to quit R. 
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After starting the R Graphical User Interface (GU I), see Packages 

•

• 

Set CRAN mirro 
File Edit View Misc Packages Windows Help 

�� !§]Ii]� Load package .. . 

R RConsole 

R version ,;.;.o 
Copyright (C) 201 
Platform: x86_6i· 

Sd CRAN mirror ... 

Select repositories ... 

Install package(s) .. . 

Update packages .. . 

Install package(s) from local files ... 

CompuL.ing 

R is free software and comes with ABSOLUTELY NO WARRANTY. 

You are welco�e to rea1,cr1bute lt under certain condltlon,. 
Type 'license{)• or 'licence()• for distribution details. 

Natural language support buc running in an English locale 

R 1s a collaborative project with many contributors. 

Type 'contributors()' for more inforrr�tion and 

'c itation()' on how to cite R or R paeka9es in publications. 

Type 'demo()' for some demos, 'help()' for on-line help, or 
'help.start()' tor an ii'IML browser in'tertace 'tO help. 

• 

r then 

• 

Se<ute CRAN nwrott 
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Use 'Packages> Load Package . • • 
I

' .. install 'Rcmdr': select menu 'Packages> Install 
I 

• ••
.--------------------------

<it RGui 

File Edit View Mjsc Pacbges Windows Help 

R RConsole 

R version 1.1:.0 
Copyrioht (C) 20: 
Plactorm: xS6_M.• 

Load package ... 

Set CRAN mirr01 .. . 

Sele-ct repositories .. . 

lnst6U p•ckagc{s) .. . 

Update packages .. . 

Inst.ti! p•ckagc{s) from local files ... 

R is free software and comes with ABSOLUTELY NO WAARA..'-ITY. 
You are welcome to redistribute it under certain conditions. 
Type 'license()' or 'licence(}' for distribution dctail3. 

Natural lanqua9e support buc runninq in an tnqlish locale 

R is a  collaborative pro)ecc wich �Any concr1bucors. 
Type 'concributors()' for more informacion and 
'citation(}' on how to cite R or R packaQe3 in publication3. 

Type 'dell'IO()' for some demos, 'help()' for on-line help, or 
'help.start{)' for an HTML browser interface co help. 
Type 'q()' to quit R. 
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After starting the R Graphical User Interface (GU I), see Packages

• 

• 

• 

Set CRAN mirro 
File Edit View Misc Packages Windows Help 

�� !§]Ii]� Load package .. . 

R RConsole 

R version ,;.;.o 
Copyright (C) 201 
Platform: x86_6i· 

Sd CRAN mirror ... 

Select repositories ... 

Install package(s) .. . 

Update packages .. . 

Install package(s) from local files ... 

CompuL.ing 

R is free software and comes with ABSOLUTELY NO WARRANTY. 

You are welco�e to rea1,cr1bute lt under certain condltlon,. 
Type 'license{)• or 'licence()• for distribution details. 

Natural language support buc running in an English locale 

R 1s a collaborative project with many contributors. 

Type 'contributors()' for more inforrr�tion and 

'citation()' on how to cite R or R paeka9es in publications. 

Type 'demo()' for some demos, 'help()' for on-line help, or 
'help.start()' tor an ii'IML browser in'tertace 'tO help. 

• 

r then 

• 

Se<ute CRAN nwrott 
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Use 'Packages> Load Package. • • 
I

Given a few moments' time, 

' .. install 'Rcmdr': select menu 'Packages> Install 
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File Edit View Mjsc Pacbges Windows Help 
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Load package ... 

R RConsole 

R version 1.1:.0 
Copyrioht (C) 20: 
Plactorm: xS6_M.• 

Set CRAN mirr01 .. . 

Sele-ct repositories .. . 

lnst6U p•ckagc{s) ... 
Update packages ... 

Inst.ti! p•ckagc{s) from local files ... 

R is free software and comes with ABSOLUTELY NO WAARA..'-ITY. 
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Type 'license()' or 'licence(}' for distribution dctail3. 
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Type 'contributors()' for more information and 
'citation(}' on how to cite R or R packaoes in publications. 
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Type 'q()' co quic R. 
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After starting the R Graphical User Interface (GUI), see Packages
• Set CRAN mirror, then …install ‘Rcmdr’: select menu ‘Packages > Install…’

• Use ‘Packages > Load Package…’ OR Enter “library(Rcmdr)” at “>”

• Given a few moments’ time, Rcmdr GUI will ‘pop up’
• ‘originating’ R GUI window will stay “in the background”

How to start R Commander: install & load ‘Rcmdr’

This remains “behind 
the scenes” of Rcmdr;

TILL you need a GRAPH!



Things to note in R Commander: menus/ panels 
Menu follows that of many cross-platform applications' GUls 

• File / Edit / ... / Help

• '' ... " = Application-specific menus:

• 'Data'/ 'Statistics'/ 'Graphs' / 'Models'/ 'Distributions'/ 'Tools'

• ... the menu names are intuitive to invite you to browse for what you want!

• ''Ribbon'' below the File/Edit/&c. is effectively a 'mini-dashboard'

• To immediate right of 'R' logo: ''active'' Data set name in red (OR 'no active')

• In between Data Set indicator & Model indicator: buttons to edit/view data

• To far right of 'R' logo: ''active'' Model name in red (OR 'no active')
\If R Commander 

File Edit Data Statistics Graphs Models Distributions Tools Help 

Data set [ <No active dataset> I / Edit data set � View data set Model: [ I: < No active model>] 

- D X 



• Menu follows that of many cross-platform applications’ GUIs
• File / Edit / … / Help
• “…” = Application-specific menus:

• ‘Data’ / ‘Statistics’ / ‘Graphs’  / ‘Models’ / ‘Distributions’ / ‘Tools’
• …the menu names are intuitive to invite you to browse for what you want!

• “Ribbon” below the File/Edit/&c. is effectively a ‘mini-dashboard’
• To immediate right of ‘R’ logo: “active” Data set name in red (OR ‘no active’)
• In between Data Set indicator & Model indicator: buttons to edit/view data
• To far right of ‘R’ logo: “active” Model name in red (OR ‘no active’)

Things to note in R Commander: menus / panels

If in BLUE can provide data options 
or model diagnostics, like:



Loading, Orientation to Rcmdr GUl's panels/menus 

• After menu-load OR entering below in R GUl's 'console' prompt see:

> library(Rcmdr)

We will next break down these panels 

R Script R Markdown � Note distinct tabs* in top panel 

Output 

I * For now, we stick to Script tab in top panel; R Markdown covered later 
Messages 

[3) NOTE: gello wilkinskj 

qt R Commander 

File Edit Data Statistics Graphs Models Distributions Tools Help 

"' Data sd: < No actJW: dataset> L Edit data set Vi� data set 

R Script R Markdown 

• 

Output 

Mes:Sbges 

[ 4) WARNING: The Windows version of the R Corcn:ander w:>rks best :l.."lder [(3J!IOTE: Mello wilkinotj 

Model: % <No lcttve: model> 

RGui wi-h t:!1e si!'lgle-doc:.nnent 1!'lterface (SDI) • see ?C .... rrma!'lder. [�!I WARNING: The Windows version o! <he R Commander worts bes< under 
i..... • • .. • • 1 • - • RGu1 with the sinole-documene 1nterf"ace (SDI); see ?COrL""Cander. 

- D X 

• 

► 

i,Subm� 

.. 

►



Loading, Orientation to Rcmdr GUl's panels/menus 

• After menu-load OR entering below in R GUl's 'console' prompt see:

> library(Rcmdr)
mander - D X 

File Edit Data Statistics Graphs Models Distributions Tools Help 

We w i 11 next b re a k d Own these pa n e Is .--!
�-:·:__-•et _<No•_ct""d_•1••">_L_Editd_•1••"_v;_.,.data_, .. _Mod•_I: X <_N01ctiv,_m•d-•I> --------, 

R Script R Markdown � Note distinct tabs* in top panel 

Output 

I * For now, we stick to Script tab in top panel; R Markdown covered later 
Messages 

[3) NOTE: gello wilkinskj 

' . 

Output 

Mes:Sbges 

[ 4) WARNING: The Windows version of the R Corcn:ander w:>rks best :l.."lder [(3J!IOTE: Mello wilkinotj 

RGui with t:!1e si!'lgle-doc:.nnent 1!'lterface (SDI) ; see ?C<:>n:ma!'lder . [�!I WARNING: The Window• version o! <he R Commander worts bes< under 

--------------------------- 1
RGu1 with the sinole-documene 1nter�ace (SDI); see ?COrL""Cander. 

• 

i,Subm� 



Loading, Orientation to Rcmdr GUl's panels/menus 

• After menu-load OR entering below in R GUl's 'console' prompt see:

> library(Rcmdr)

We will next break down these panels, 

R Script R Markdown � Note distinct tabs* in top panel 

Output 

I * For now, we stick to Script tab in top panel; R Markdown covered later

Messages 

[3) NOTE: gello wilkinskj 

[4) WARNING: The Windows version of the R Corr.n:ander w�rks best :1..�der 

RGui with t�e single-doc:.nnent interface (SDI); see ?C�n:mander. 

qt R Commander - D 

Fil• Edit Data Statistics Graphs Mod•ls Distributions Tools H•lp 

Data sd: < No actJW: dataset> L Edit data stt Vi� data set Mod•I: % <No lcttve: modtl> 

RScnpt RM,,-, 

• 

Output 1' Submt 

Mes:Sbges ITTDOTE: Hello w1lk1nskj

WARNING: The Windows version ot �he R Commander worts bes� under 

1
RGu1 with the sinole-documene 1nter�ace (SDI); see ?COrL""Cander. 

• 

I 



• After menu-load OR entering below in R GUI’s ‘console’ prompt see:
> library(Rcmdr)

We will next break down these panels

Loading, Orientation to Rcmdr GUI’s panels/menus

 Note distinct tabs* in top panel

* For now, we stick to Script tab in top panel; R Markdown covered later



• Top Panel: can toggle by 'tab' between

'R Script' & 'R Markdown'

• 'R Script' panel: an edit-ready sub­

window where code a ears

• 'Output' panel: a non-editable sub­

"-R R Commander 

file £.dit �tw _Misc fackages Windows tielp 

R RConsote 

R version 4.4.0 {2024-04-24 ucre) -- "Puppy Cup" 
Copyriqhe (C) 2024 The R Foundaeion for Stati.seical Co1tputinq 
Platform: x86_64-w64-m.1ngw32/x61 

R is free software and co�s wieh ABSOLUT!:LY NO WARR.ANTY.\ltr«iui 
You are welcome to redistribute it under certain conditic £it ldit Y.ew MiK t•<bgH Wi"6owl t:idp 
Type • licen,e () • or •licence() • for dia<ribucion decail•. l�ft,"!lil)l!Qf e,fol � �

Natural lanquaqe support but runninq in an Enqlish loc • RConsol, 

> llbruvtRcmdr)
R is a collaborae1.ve project wieh many contri,bueors. t.oad1.no uqu1nd pack6oe: .spllnu
Type •contributors()• for more information and Load1.no nquued pact•oe: Rc:actrKlac 
'citation()' on how to cite R or R pa.ckaqe.s in publicati Load1.no Ultl)lUd pack•o•: eu: 

i.Oa<l1.nq Ultl)l.Ud pact•o•: euO.t• 
Loacl1n9 req1.ared pack•oe: sanch,1ch 

Type 'de�()' for some dell'lOs, 'help()' for on-line help, !.oad1.n9 :-equued pact:a9e: etf'eets 
'help.start()• for an HTML browser interface to help. lattice the:r.e .set by ef'tect5The:r.et) 
Type 'q(), to quit R. Su ?etf'ectat'heiu tor details. 

> 11.brary(Rcmdr) 

. . - . 

- □ X 

ftle Edrt Oata Statistics Graphs Models Distributions Tools Help 

"' D1t1 stt <No 1ctive d1t1stt> L Edit d1t1 sd 

R Script R Martcdown 

View dlll set Modtl: J. <No lctlVt mo-dd>] 

.. 

window that 'echoes' code already 

submitted to R 'console' & text-based 1

•

Output i Subm� 

.. 

• 

.. 

output when appropriate

• 'Messages' panel: a non-editable sub­

window to 'surfaces' R system 'reply'

messa es for code a/read submitted
Mess�ges 

[3) NOT!: Mello w1lk1nskj 
[1) WARNING: The Windows version of the R Commander worts best under 
RGu1. w1.ch the s1nqle-documenc interface (SDI); see ?Coa:mander. 

.. 

•



• Top Panel: can toggle by 'tab' between

'R Script' & 'R Markdown' RScript

• 'R Script' panel: an edit-ready sub­

window where code a ears

• 'Output' panel: a non-editable sub­

"-R R Commander 
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R RConsote 
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Type •contributors()• for more information and Load1.no nquued paet•oe: Rc:actrKlae 
'citation()' on how to cite R or R pa.ckaqe.s in publicati to.d1.no r♦ltl)iud paet•o•: eu: 

i.Oa<l1.nq Ultl)l.Ud paet•o•: euO.t.• 
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'help.start()' for an HTML browser interface to help. lat.tiee the:r.e set by ef't'eetsThe:r.et)
Type 'q(), to quit R. Su ?etf'eetat'heiu tor details. 

> 11.brary(Rcmdr) 

- □ X 

ftle Edrt Oat<1 Statistics Gr<1phs Models Distributions Tools Help 

"' 0<1t1 stt <No 1ctive d1t1stt> L Edit d1t1 sd 

R-

View d1t1 set Modtl: J. <No <1ct1Vt mo-dd>] 

window that 'echoes' code already

submitted to R 'console' & text-based 1
Output i Subm� 

.. 

output when appropriate

• 'Messages' panel: a non-editable sub­

window to 'surfaces' R system 'reply'

messa es for code a/read submitted
Mtsugts 

[3) NOT!: Mello w1lk1nskj 
[1) WARNING: The Windows version of the R Commander worts best under 
RGui wich the s1n9le-documenc interface (SDI); see ?Coa:mander. 

•

• 



• Top Panel: can toggle by 'tab' between

'R Script' & 'R Markdown' RScript

• 'R Script' panel: an edit-ready sub­

window where code a ears

• 'Output' panel: a non-editable sub­

"-R R Commander 
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R RConsote 
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Natural lanquaoe suppore bue runninq in an Enqlish loc • RConsol, 

> llbruvtRcmdr) 
R is a collaborae1.ve project wieh many contri,butors. t.oad1.no uqu1nd pack6oe: .spllnu 
Type •contributors()• for more information and Load1.no nquued paet•oe: Rc:actrKlae 
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"' 0<1t1 stt <No 1ctive d1t1stt> L Edit d1t1 sd 

R-

View d1t1 set Modtl: J. <No <1ct1Vt mo-dd>] 

window that 'echoes' code already

submitted to R 'console' & text-based
Output i Subm� 

.. 

• 'Messages' panel: a non-editable sub­

window to 'surfaces' R system 'reply'

messa es for code a/read submitted
Mtsugts 

[3) NOT!: Mello w1lk1nskj 
[1) WARNING: The Windows version of the R Commander worts best under 
RGui wich the s1n9le-documenc interface (SDI); see ?Coa:mander. 
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• Top Panel: can toggle by 'tab' between

'R Script' & 'R Markdown' RScript

• 'R Script' panel: an edit-ready sub­

window where code a ears

• 'Output' panel: a non-editable sub­

window that 'echoes' code already

submitted to R 'console' & text-based

out ut when ap(2rO riate Output

• 'Messages' panel: a non-editable sub­

window to 'surfaces' R system 'reply'

messa &v for code a/read submitted
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"' 0<1t1 stt <No 1ctive d1t1stt> L Edit d1t1 sd View d1t1 set Modtl: 1. <No <1ct1Vt mo-dd>] 

R-

o..,tput 

Mtsugts 

[3) NOT!: Mello w1lk1nskj 
[1) WARNING: The Windows version of the R Commander worts best under 
RGui w1ch the s1n9le-documenc interface (SDI); see ?Coa:mander. 



• Top Panel: can toggle by 'tab' between
'R Script' & 'R Markdown' RScript 

• 'R Script' panel: an edit-ready sub­
window where code a ears 

• 'Output' panel: a non-editable sub­
window that 'echoes' code already

submitted to R 'console' & text-based 
out ut when ap(2rO riate Output

•I 'Messages' panel: la non-editable sub­
window to 'surfaces' R system 'reply' 
messa &v for code a/read submitted
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• Top Panel: can toggle by ‘tab’ between
‘R Script’ & ‘R Markdown’

• ‘R Script’ panel: an edit-ready sub-
window where code appears

• ‘Output’ panel: a non-editable sub-
window that ‘echoes’ code already 
submitted to R ‘console’ & text-based 
output when appropriate

• ‘Messages’ panel: a non-editable sub-
window to ‘surfaces’ R system ‘reply’ 
messages for code already submitted

Things to note in Rcmdr: panels

R Script

Output



'File' Menu: can select an active 

'working' directory or OpSys 'folder' 

• Why? easier to select files to import

• 'R Script' panel: shows 'submitted'

setwd( ... ) call, with OS-chosen 'folder'

• 'Output' panel: 'echoes' it

• Next choice in 'File' menu:

File Edit Data Statistics Graphs Models Distributions Tools Help 

Change working directory ... 

Open script file ... 
Save script... 
Save script as ... 

Open R Markdown file .. . 
Save R Markdown file .. . 
Save R Markdown file as ... 

Save output. .. 
Save output as ... 

Save R workspace ... 
Save R workspace as ...

Exit 

_ t> _' Edit data set � View data set

►



'File' Menu: can select an active 

'working' directory or OpSys 'folder' 

• Why? easier to select files to import

• 'R Script' panel: shows 'submitted'

setwd( ... ) call, with OS-chosen 'folder'

• 'Output' panel: 'echoes' it

• Next choice in 'File' menu:

Open script file ... 

Save script. .. 

Save script as ... 

Open R Markdown file .. . 

Save R Markdown file .. . 

Save R Markdown file as ... 

Save output ... 

Save output as ... 

Save R workspace ... 

Save R workspace as ...

Exit ►



'File' Menu: can select an active 

'working' directory or OpSys 'folder' 

Graphs Models Distributions Tools Help 

• Why? easier to select files to import

• 'R Script' panel: shows 'submitted'

setwd( ... ) call, with OS-chosen 'folder'
lR R Commander 

Open script file ... 

Save script. .. 

Save script as ... 

Open R Markdown file .. . 

Save R Markdown file .. . 

Save R Markdown file as ... 

Save output ... 

Save output as ... 

Save R workspace ... 

Save R workspace as ...

Exit 

• 'Output' panel: 'echoes' it File Edit Data Statistks G11phs Models DistributK>ns Tools Help 

'-ft-' Oaa set: < No active da� L Edit data set View daU set Model: L < No actrve � 

R Script R Markdown 

► 

• Next choice in 'File' menu: seewd(wC:/Osers/wilt�nskj/oneorive - Nac1onal Inseieuees ot Healch/Do�nes/Ineramural 

Output 

.. 



'File' Menu: can select an active 

'working' directory or OpSys 'folder' 

• Why? easier to select files to import

• 'R Script' panel: shows 'submitted'

setwd( ... ) call, with OS-chosen 'folder'
lR R Commander

Open script file ... 

Save script. .. 

Save script as ... 

Open R Markdown file .. . 

Save R Markdown file .. . 

Save R Markdown file as ... 

Save output ... 

Save output as ... 

Save R workspace ... 

Save R workspace as ...

Exit 

• 'Output' panel: 'echoes' it File Edit Data Statistks G11phs Models DistributK>ns Tools Help 

• Next choice in 'File' menu:
'-ft-' Oaa set: < No active da� L Edit data set View daU set Model: L < No actrve � 

Output 

►



'File' Menu: can select an active 

'working' directory or OpSys 'folder' 

• Why? easier to select files to import

• 'R Script' panel: shows 'submitted'

setwd( ... ) call
, 
with OS-chosen 'folder' 

Open script file ... 

Save script. .. 

Save script as ... 

Open R Markdown file .. . 

Save R Markdown file .. . 

Save R Markdown file as ... 

Save output ... 

Save output as ... 

Save R workspace ... 

Save R workspace as ...

Exit 

• IO u t p u t I p a n e I : 'e C h O e s, i t : R :::m�::." �•tirtks G .. phs Mod•I• O�ribut�n, Tools H•lp

._ _____________ __. '-ft-' Oaase.t: <Noactiveda� LEd"itdataset ViewdaUset Model: L <Noactrve� 

► 

N t h . . 'F.I , • e X C O IC e I n I e men u : secvd("C:/Useu/w11t1nsk)/0neDnve - :iauonal !nsuouoes of Healoh/Doc:,mencs/Incramural 

Output 



‘File’ Menu: can select an active 
‘working’ directory or OpSys ‘folder’
• Why? easier to select files to import
• ‘R Script’ panel: shows ‘submitted’
setwd(…) call, with OS-chosen ‘folder’

• ‘Output’ panel: ‘echoes’ it
• Next choice in ‘File’ menu:

Things to use in Rcmdr: Filesystem via File>



Orientation within Rcmdr GU l's panels/menus 

• Appearances of each (color-coding), by panel

• R Script: 'Submitted' code in Black
R Script R Markdown 

setwd("C:/Osers/wilkinskj/OneDrive - National Institutes of Health/Docureents/ 

• Output: 'Echoed' submission of code in Brown

Output 

• Messages
l> setwd("C,/Users/wilkinskj/OneOrive - National Institutes of Health/Ooc=ents/

• Notes in Blue Messages 

(l] NOTE: R ComJnander Version 2.9-2: Thu Jul 24 l�:53:46 202� 
(2] NOTE: R Version 4.4.O 
(3] NOTE: Hello wilkinskj 

• Warnings in Green Messages 

• Errors in Red
Messages 

(4] WARNING: The Windows version of the R Commander works best under 
RGui with the single-document interface (SDI); see ?Commander. 

(5] ERROR: The=e is no active data set. 
(6] ERROR: There is no active data set. 
(71 ERROR: There are no data sets from which to choose. 

YEARS 

NI DD K '9so-20�" 



• 

Orientation within Rcmdr GU l's panels/menus 

Appearances of each (color-coding), by panel 

r R Script:! 'Submitted' code in Black
R Script R Markdown 

setwd("C:/Users/wilkinskJ/OneDrive - National Institutes of Health/Docureents/ 

• Output: 'Echoed' submission of code in Brown

• Messages

• Notes in Blue

Output 

Messages 

(l] NOTE: R ComJnander Version 2.9-2: Thu Jul 24 l�:53:46 202� 
(2] NOTE: R Version 4.4.O 
(3] NOTE: Hello wilkinskj 

• Warnings in Green Messages

• Errors in Red

@ 

Messages 

(4] WARNING: The Windows version of the R Commander works best under 
RGui with the single-document interface (SDI); see ?Commander. 

(5] ERROR: The=e is no active data set. 
(6] ERROR: There is no active data set. 
(71 ERROR: There are no data sets from which to choose. 

YEARS 

NI DD K '9so-20�" 



• Appearances of each (color-coding), by panel
• R Script: ‘Submitted’ code in Black

• Output: ‘Echoed’ submission of code in Brown

• Messages
• Notes in Blue

• Warnings in Green

• Errors in Red

Orientation within Rcmdr GUI’s panels/menus



• 

• 

• 

• 

Rcmdr menus/panels with some 'history' 

Top Panel: keeping to 'R Script' tab 

(currently, 'R Markdown' for later) 

'R Script': code appears in Black as 

you select actions on data via menu 

'Output': 'echoes' code prior 

submitted to R 'console' (in bkgrnd) 

in Brown WHILE text-based output 

in Blue, as applicable ... graphs later 

'Messages': 'surfaces' R system 

Notes in Blue while 'reply' messages 

for code already submitted giving 

Warnings in Green & Errors in Red 

\Jl R Commander D 

File Edit Oata Statistics Graphs Models Distributions Tools Help 

� Data set I rr DIG data I L. Edit data set � View data set Model: I :i: < No active model> I 

R Script R Markdown 

setwd("C:/Osers/wilkinskj/OneDrive - National Institutes of Health/Documents/lntrarnural/_BiostatsStrategy-in-IRP/Semina: 
CTGdata <-

read.table("C:/Users/wilkinskj/OneDrive - National Institutes of Health/Documents/Intramural/_BiostatsStrategy-in-IRP, 
headeI=TRUE, stringsAsFactors=TRUE, sep=",", na.strings="", dee=".", strip.white=TRUE) 

CTGdata <-
reaclXL("C:/Users/wilkinskj/OneDrive - National Institutes of Health/Documents/Intramural/_BiostatsStrategy-in-IRP/Sem: 

rownames=FALSE, header=TRUE, na="", sheet="ctg-studies CSV", stringsAsFactors=TRUE) 
summary (CTGdata) 
library(abind, pos•l6) 

Output 
�*Submit 

> setwd(nc:/Osers/wilkinskj/OneDrive - National Institutes of Health/Documents/Intramural/_BiostatsStrategy-in-IRP/Semi 

> CTGdat.a <-
+ read.table{"C:/Use�s/wilkinskj/OneDrive - National Institutes of Health/Documents/Intramu�al/_BiostatsStrategy-in-I
+ header=TRUE, stringsAsFactors=TRUE, sep=", ", na. strings="", dee=".", strip. white=TRUE)

> CTGdata <-
+ reaclXL("C:/Users/wilkinskj/OneDrive - National Institutes of Health/Documents/Intramural/_BiostatsStrategy-in-IRP/5
+ rownames=FALSE, header=TROE, na=u ", sheet="ctg-studies CSV", stringsAsFactors=TRUE)

> summary(CTGdata)
NCT.Number 

NCT00001723: l 
NCTOOOOS669: l 
NCT00025883: l 
NCT00062764: 1 
NCT00063232: 1 
NCT007ll490: l 
(01:her) : 10 

Messages 

[11 NOTE: R Commander Version 2.9-2: Thu Jul 24 16:53:46 2025 
[2) NOTE: R Version 4.4.0 
[3] NOTE: Hello wilkinskj
[4) WARNING: The Windows version of the R Co�.mander works best under

.. 



• Top Panel: keeping to ‘R Script’ tab
(currently, ‘R Markdown’ for later)

• ‘R Script’: code appears in Black as 
you select actions on data via menu

• ‘Output’: ‘echoes’ code prior 
submitted to R ‘console’ (in bkgrnd) 
in Brown WHILE text-based output 
in Blue, as applicable… graphs later

• ‘Messages’: ‘surfaces’ R system 
Notes in Blue while ‘reply’ messages 
for code already submitted giving 
Warnings in Green & Errors in Red

Rcmdr menus/panels with some ‘history’ 



• 

Orientation within Rcmdr GU l's menus: Data (1) 

Importing data from multiple formats 

• Exce I-ab I e fi I es: .csv or .xlsx (or character-delimited .txt files); NUANCED

• Other analytic platforms' files: SAS (.sas7bdat) or Stata or SPSS

• Each 'file'/'worksheet' becomes a R 'data. frame'

\.ft' R Commander 

File Edit Data Statistics Graphs Models 

D
J--New data set...

Load data set. .. 

Distributions Tools Help 

l set � View data

R Script R Merge data sets ...
================:::::r-

'--
-----

Active data set 
Manage variables in active data set 

from text file, clip 
from SPSS data SE 
from SAS xport fil 
from SAS b7dat fi 
from Minitab dat, 
from STATA data 
from Excel file ... 

• Designating ingest settings, becom.es Active data
qr Read Text Data From file, Clipboard, or URL 

Enter name for data set: CTGdatal 
Variable names in file: II

Convert character variables to factors II
Missing data indicator: 
Location of Data File 
0 Local file system 
Q Clipboard 

0 Internet URL 
Field Separator 
0 White space O Commas [,) 

0 Semicolons�) 0 Tabs 

0 Other Specify: 
Decimal-Point Character 
0 Period[.) 
0 Comma[,) 

@Help .,/ OK )C Cancel 

X (R' Read Text Data From File, Clipboard, or URL 

Ente.r name for data set Dataset 

X 

------

Variable names in file: II 

Convert character variables to factors II
Missing data indicator: NA 
Location of Data File 
0 Local file system 
0 Clipboard 
0 Internet URL 
Field Separator 
0 White space O Commas LI 
0 Semicolons �) 0 Tabs 
0 Other Specify: 
Decimal-Point Character 
0 Period(.) 
0 Comma(,) 

@Help 

---

,C Cancel 

� R Commander 

File Edit 

R Da 

R Script R 

Data Statistics Graphs Models 

New data set ... 

Distributions 
7

set 

Tools Help

View data set 
Load data set ... 
Merge data sets ... 

------------------,�============= 

Import data ► 

Data in packages 
Active data set 
Manage variables in active data set 

► 

► 

► 

from text file, clipboard, or URL. .. 
from SPSS data set. .. 
from SAS xport file .. . 
from SAS b7dat file .. . 
from Minitab data set ... 
from STATA data set... 
from Excel file ... 



• 

Orientation within Rcmdr GU l's menus: Data (1) 

Importing data from multiple formats 

• Exce I-ab I e fi I es: .csv or .xlsx (or character-delimited .txt files); NUANCED

• Other analytic platforms' files: SAS (.sas7bdat) or Stata or SPSS

• Each 'file'/'worksheet' becomes a R 'data. frame'

\.ft' R Commander 

File Edit Data Statistics Graphs Models 

D
J--New data set...

Load data set. .. 

Distributions Tools Help 

l set � View data

R Script R Merge data sets ... 
================:::::r-

'--
-----

Active data set 
Manage variables in active data set 

from text file, clip 
from SPSS data SE 
from SAS xport fil 
from SAS b7dat fi 
from Minitab dat, 
from STATA data 
from Excel file ... 

• Designating ingest settings, becom.es Active data
qr Read Text Data From file, Clipboard, or URL 

Enter name for data set: CTGdatal 

Convert character variables to factors ■ 
Missing data indicator: 
Location of Data File 
0 Local file system 
Q Clipboard 

0 Internet URL 
Field Separator 
0 White space O Commas I.I
0 Semicolons �I O Tabs 

0 Other Specify: 
Decimal-Point Character 
0 Period I.) 
0 Comma I.I

@Help .,/ OK )C Cancel 

X (R' Read Text Data From File, Clipboard, or URL 

Ente.r name for data set Dataset 

Convert character variables to factors ■ 
Missing data indicator: NA 
Location of Data File 
0 Local file system 

0 Clipboard 
0 Internet URL 
Field Separator 
0 White space O Commas LI 
0 Semicolons �I O Tabs 

0 Other Specify: 
Decimal-Point Character 
0 Period(.) 
0 Comma(,) 

@Help 

---

,C Cancel 

X � R Commander 

File Edit 

R Da

R Script R 

Data Statistics Graphs Models 

New data set ... 

Distributions 

7
set 

Tools Help 

View data set 
Load data set ... 
Merge data sets ... 

------------------,�============= 

Import data ► 

Data in packages 
Active data set 
Manage variables in active data set 

► 

► 

► 

from text file, clipboard, or URL. .. 
from SPSS data set. .. 
from SAS xport file .. . 
from SAS b7dat file .. . 
from Minitab data set ... 
from STATA data set... 
from Excel file ... 



• 

Orientation within Rcmdr GU l's menus: Data (1) 

Importing data from multiple formats 

• Exce I-ab I e fi I es: .csv or .xlsx (or character-delimited .txt files); NUANCED

• Other analytic platforms' files: SAS (.sas7bdat) or Stata or SPSS

• Each 'file'/'worksheet' becomes a R 'data. frame'

\.ft' R Commander 

File Edit Data Statistics Graphs Models 

D
J--New data set...

Load data set. .. 

Distributions Tools Help 

l set � View data

R Script R Merge data sets ... 
================:::::r-

'--
-----

Active data set 
Manage variables in active data set 

from text file, clip 
from SPSS data SE 
from SAS xport fil 
from SAS b7dat fi 
from Minitab dat, 
from STATA data 
from Excel file ... 

• Designating ingest settings, becom.es Active data
qr Read Text Data From file, Clipboard, or URL 

Enter name for data set: 

Missing data indicator: 

0 local file system 
Q Clipboard 

0 Internet URL 
Field Separator 
0 White space O Commas I.I
0 Semicolons �I O Tabs 

0 Other Specify: 
Decimal-Point Character 
0 Period I.) 
0 Comma I.I

@Help .,/ OK 

CTGdatal 

)C Cancel 

X (R' Read Text Data From File, Clipboard, or URL 

Ente.r name for data set 

Missing data indicator: 

0 local file system 

0 Clipboard 
0 Internet URL 
Field Separator 
0 White space O Commas LI 
0 Semicolons �I O Tabs 

0 Other Specify: 
Decimal-Point Character 
0 Period(.) 
0 Comma(,) 

@Help 

Dataset 

NA 

,C Cancel 

X � R Commander 

File Edit 

R Da

R Script R 

Data Statistics Graphs 

New data set ... 
Load data set ... 
Merge data sets ... 

Models Distributions 

7
set 

Tools Help 

View data set 

------------------,�============= 

Import data ► 

Data in packages 
Active data set 
Manage variables in active data set 

► 

► 

► 

from text file, clipboard, or URL. .. 
from SPSS data set. .. 
from SAS xport file .. . 
from SAS b7dat file .. . 
from Minitab data set ... 
from STATA data set... 
from Excel file ... 



• 

Orientation within Rcmdr GU l's menus: Data (1) 

Importing data from multiple formats 

• Exce I-ab I e fi I es: .csv or .xlsx (or character-delimited .txt files); NUANCED

• Other analytic platforms' files: SAS (.sas7bdat) or Stata or SPSS

• Each 'file'/'worksheet' becomes a R 'data. frame'

\.ft' R Commander 

File Edit Data Statistics Graphs Models 

DJ--New data set...
Load data set. .. 

Distributions Tools Help 

l set � View data

R Script R Merge data sets ... 
================:::::r-

'--
-----

Active data set 
Manage variables in active data set 

from text file, clip
from SPSS data SE 
from SAS xport fil 
from SAS b7dat fi 
from Minitab dat, 
from STATA data 
from Excel file ... 

• Designating ingest settings, becom.es Active data
qr Read Text Data From file, Clipboard, or URL 

Enter name for data set: 

Missing data indicator: 

0 local file system 
Q Clipboard 

0 Internet URL 

0 Other Specify: 
Decimal-Point Character 
0 Period [.I 
0 Comma I.I 

@Help 

CTGdatal 

)C Cancel 

X (R' Read Text Data From File, Clipboard, or URL 

Ente.r name for data set 

Missing data indicator: 

0 local file system 

0 Clipboard 
0 Internet URL 

0 White space O Commas LI

0 Other Specify: 
Decimal-Point Character 
0 Period(.) 
0 Comma(,) 

@Help 

Dataset 

NA 

,C Cancel 

X � R Commander

File Edit Data Statistics Graphs Models Distributions 

7
set 

Tools Help 

R Da

R Script R 

New data set ... 
Load data set ... 
Merge data sets ... 

View data set 

------------------,�============= 

Import data ► 

Data in packages 
Active data set 
Manage variables in active data set 

► 

► 

► 

from text file, clipboard, or URL. .. 
from SPSS data set. .. 
from SAS xport file .. . 
from SAS b7dat file .. . 
from Minitab data set ... 
from STATA data set... 

from Excel file ... 



• Importing data from multiple formats
• Excel-able files: .csv or .xlsx (or character-delimited .txt files); NUANCED

• Other analytic platforms’ files: SAS (.sas7bdat) or Stata or SPSS

• Each ‘file’/‘worksheet’ becomes a R ‘data.frame’

• Designating ingest settings, becomes Active data

Orientation within Rcmdr GUI’s menus: Data (1)



Orientation within Rcmdr GU l's menus: Data (2) 

• For sake of REPRODUCIBILITY, we can save 'R Script' code made so far
f",lf [die o.t, St.e.-ot, � Modclt � 1ocili, � 

Chlntt��- �(6tdf,u'°" 11"'-dfiUlofl MoM •�Uo�•nockb 
O,-tc•r•­

,._.,__ 

l•+m;; lci:I..P --f<-0t1,t>r1<re • ••uoti•l l1Ut1tvu, Of l!e..ttll/Docuwttu/ttltr.-Ue. 

--

,.,. ....... � 

s...•� ... 

s... •-"-"f«• -

"' 

•1n,k)/OM.Df1•e - ll•non,.i 1r:1,ut1;1�• of !ledt.lllooci-t1t--t/ln: 
�Wl•"'1'IRI. ••P"'•,•. ne.,;i;a.n,;,•••, dot<:'"•,•· •tllP•"lllt♦.."fAi 

1;,10r .. ou..-, - "•uon..l tn,ut\lt•• or 11,,u.ll/Cioc,,:;:,wcnt.9/Jr.u .. 

Tllt!C, ,._. .... , ellNt••eir.9-•t,.,:u.,, CSV•, •tr11<Q,.i..f',ctor1'"'ft\!1:) 

YEARS 

NI DD K '9so-20�" 



Orientation within Rcmdr GU l's menus: Data (2) 

• For sake of REPRODUCIBILITY, we can save 'R Script' code made so far
Mes�ages 

f",lf [die o.t, St.e.-ot, � Modclt � 1ocili, � 

Chlntt��- �(6tdf,u'°" 11"'-dfiUlofl MoM •�Uo�•nockb 
O,-tc•r•­

,._.,__ 

l•+m;; lci:I..P --f<-0t1,t>r1<re • ••uoti•l !IUlt1tVU• Of l!e..ttll/Docuwttu/ttltr.-Ue. 

-
1 
_.,..._ (10] NOTE: The dataset CTGdata has 16 rows and 19 columns. 

.... .,, ..... m-,moMllom<>"'"""""'"'-••"'·---

(11] NOTE: Script saved to C:/Users/wilkinskj/OneDrive - National Institutes of 

--
,.,. ....... � 

s...•� ... 

s... •-"-"f«• -

�Wl•"'1'IRI. ••P"'•,•. ne.,;1;a.n,;1•••, dot<:'"•,•· •tllP•"lllt♦.."fAi 

1;,10r .. ou..-, - ,i,uon..l tn,ut\lt•• or 11,,u.ll/Cioc,,:;:,wcnt.9/Jr.u .. 
Tllt!C, ,._. .... , ellNt••eir.9-•t,.,:u.,, CSV•, •tr11<Q1.i..f',ctor1'"'ft\!1:) 

NOTE: as this is an operating-system-level action, it only gets shown by 

Rcmdr in Blue rather than being 'echoed' as R commands in Output in Brown 
"' 

YEARS 

NI DD K '9so-20�" 



Orientation within Rcmdr GU l's menus: Data (2) 

• For sake of REPRODUCIBILITY, we can save 'R Script' code made so far
f",lf [die o.t, St.e.-ot, � Modclt � 1ocili, � 

Chlntt��- �(6tdf,u'°" 11"'-dfiUlofl MoM •�Uo�•nockb 
O,-tc•r•-
,._.,__ 

H { I j. · I 0t1,t>r1<re • ••uoti•l l1Ut1tvu, or l!edtll/Docuwttu/tt1tr.-ue. 

0,-11.�lile... •1n,k)/OM.Df1•e - ll•uon,.i 1r:1,ut1;1�• of !ledt.lllooci-t1t--t/ln.· 

Mes�ages 

-1 ___._ (10] NOTE: The dataset CTGdata has 16 rows and 19 columns. 

(11] NOTE: Script saved to C:/Users/wilkinskj/OneDrive - National Institutes of 

S,.,.,:u.1-doa,,,Qr,... M:Ti•U•'"1'IRI. ftP"'•,•• ne.,;i;a.n,;,•••, dot<:'"•,•• •tllP•"lllt♦.."fAi 

--

,.,. ....... � 

s...•� ... 
s... •-"-"f«• -

1;,10r .. ou..-, - "•uon..l tn,ut\lt•• or 11,,u.ll/Cioc,,:;:,wcnt.9/Jr.u .. 

Tllt!C, ,._. .... , ellNt••eir.9-•t,.,:u.,, CSV•, •tr11<Q,.i..f',ctor1'"'ft\!1:) 
NOTE: as this is an operating-system-level action, it only gets shown by 

Rcmdr in Blue rather than being 'echoed' as R commands in Output in Brown 
"' 

• With .R file saved for opening & running later, can reproduce data import

• Note: if we want to save time running errors/ can remove .csv lines; NB: 'View' issues

• With imported data as an Active dataset, can make summaries

YEARS 

NI DD K '9so-20�" 



Orientation within Rcmdr GU l's menus: Data (2) 

• For sake of REPRODUCIBILITY, we can save 'R Script' code made so far
Mes�ages 

f",lf [die o.t, St.e.-ot, � Modclt � 1ocili, � 

Chlntt��- �(6tdf,u'°" 11"'-dfiUlofl MoM •�Uo�•nockb 
O,-tc•r•­

,._.,__ 

l■H!!!l{l!l1"Jj..P-■-lf<-0t1,t>r1<re • ••uoti•l !1Ut1tvu• or l!e..ttll/Docuwttu/tt1tr.-ue. 

-1 _.,..._ (10] NOTE: The dataset CTGdata has 16 rows and 19 columns .

.... .,, ..... m-,moMllom<>"'"""""'"'-••"'·---

(11] NOTE: Script saved to C:/Users/wilkinskj/OneDrive - National Institutes of 

�Wl•"'1'IRI. ••P"'•,•. ne.e;i;a.n,;,•••, dot<:'"•,•· •tllP•"lllt♦.."fAi 

1;,10r .. ou..-. - ,i,uon..l tn,ut\lt•• or ll•e1t.ll/Cioc,,:;:,wcnt.9/Jr.u .. 
Tllt!C, ,._. .... , ellNt••eir.9-•t,.,:u.,, CSV•, •tr11<Q,.i..f',ctor1'"'ft\!1:) NOTE: as this is an operating-system-level action, it only gets shown by 

Rcmdr in Blue rather than being 'echoed' as R commands in Output in Brown 

• With .R file saved for opening & running later, can reproduce data import

• Note: if we want to save time running errors/ can remove .csv lines; NB: 'View' issues

• With imported data as an Active dataset, can make summaries
� R Commander 

File Edit Data Statistics Graphs Models Distributions Tools Help 

Data set: 

R Script R Markd 

setwd ( "C: /U 
CTGda.ta. <­

read.tab! 
hea.der=T 

Summaries ► 

Contingency tables ► 

Means ► 

Proportions ► 

Variances ► 

Nonparametric t5ts ► 

Dimensional analysis ► 

Fit models ►

CTGda.ta <- --------

Active data set 

Numerical summaries ... 

Frequency distributions ... 

Count missing observations 

Table of statistics .. . 

Correlation matrix .. . 

Correlation test ... 

Test of normality ... 

Transform toward normality ... 
r i:- ;o rr'>(T _ I n r • ITT,. i:- ,- ,. I t.1 i 1 Ir i n,. lri / On i:-n,,..,..,..--..__�,,.,.,...._._...,,...............,,- .......,..,_,.....j 

YEARS 

NI DD K '9so-20�" 



Orientation within Rcmdr GU l's menus: Data (2) 

• For sake of REPRODUCIBILITY, we can save 'R Script' code made so far
Messages 

f",lf [die o.t, St.e.-ot, � Modclt � 1ocili, � 

Chlntt��- �(6tdf,u'°" 11"'-dfiUlofl MoM •�Uo�•nockb 
O,-tc•r•­

,._.,__ 

l•+m;; lci:I..P --f<-0t1,t>r1<re • ••uoti•l !IUlt1tVU• Of l!e..ttll/Docuwttu/ttltr.-Ue. 

-
1 
_.,..._ (10] NOTE: The dataset CTGdata has 16 rows and 19 columns. 

.... .,, ..... m-,moMllom<>"'"""""'"'-••"'·---

(11] NOTE: Script saved to C:/Users/wilkinskj/OneDrive - National Institutes of 

�Wl•"'1'IRI. ••P"'•,•. ne.e;i;a.n,;,•••, dot<:'"•,•· •tllP•"lllt♦.."fAi 

1;,10r .. ou..-. - ,i,uon..l tn,ut\lt•• or ll•e1t.ll/Cioc,,:;:,wcnt.9/Jr.u ..
Tllt!C, ,._. .... , ellNt••eir.9-•t,.,:u.,, CSV•, •tr11<Q,.i..f',ctor1'"'ft\!1:) NOTE: as this is an operating-system-level action, it only gets shown by 

Rcmdr in Blue rather than being 'echoed' as R commands in Output in Brown 

• With .R file saved for opening & running later, can reproduce data import

• Note: if we want to save time running errors/ can remove .csv lines; NB: 'View' issues

• With imported data as an Active dataset, can make summaries
� R Commander

File Edit Data Statistics Graphs Models Distributions Tools Help

Data set:

R Script R Markd

setwd ( "C: /U 
CTGda.ta. <­

read.tab! 
hea.der=T 

Varia
Nonp

CTGda.ta <- __ ___, 
ri:-;orr',(T_ I nr • /flqia-rq 

Active data set
Numerical summaries ...

X 

There are 19 variables in the data set CTGdata.
Do you want to proceed?

OK _ [ Cancel

@------------

YEARS 
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• For sake of REPRODUCIBILITY, we can save ‘R Script’ code made so far

• With .R file saved for opening & running later, can reproduce data import
• Note: if we want to save time running errors, can remove .csv lines; NB: 'View' issues

• With imported data as an Active dataset, can make summaries

Orientation within Rcmdr GUI’s menus: Data (2)

NOTE: as this is an operating-system-level action, it only gets shown by 
Rcmdr in Blue rather than being ‘echoed’ as R commands in Output in Brown

And Rcmdr generates a generic ‘summary’ of 
variables/columns, after command / is echoed 



Orientation to Rcmdr GUl's menus: Data➔summaries(l) 

• With Active Dataset, can do more specific summaries of interest:

• What if interested in how CTG studies/ enrollment numbers are by status?
\.R R Commander 

File Edit Data Statistics Gtaphs Models Distributions Tools Help 

Contingency tables ► Numerical summ;i,r1es 
� Dataset 

R Script R Marled Means 

Proportions 

► Frequency distributions ... 
► Count missing observations 

Varian,� 
.,etwd("C:/U 

► Table of statistics ... 

CTGdaca <· Nonparam!tric ttsts ► 

I read. cabl Dimensional analysis ► 

header-I Fit models ► 

f
T

���: .. :: .... m ........... , ..... , .... --�◄ ,,._,., 

Correbtion matrix ... 

Correlation test ... 
Test of normality ... 

Transform toward normality ... 

v� (pid:onto, � 

im::i::=--• 

O•t• StitlffiCS 
vtn,bltS (picl: Ont 0,-m,or,t) 
IMl/ui':I : 

�mMlfitt by groups-I 

X 

Groups v1n1bk (pick Of'lt) 

., OK I X C,n<tl 

X 

@"•'• ., ..... ,/ o«. I 
,c c"'"' ,+ •i>P'Y 

X 

YEARS 
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Orientation to Rcmdr GUl's menus: Data➔summaries(l) 

• With Active Dataset, can do more specific summaries of interest:

• What if interested in how CTG studies/ enrollment numbers are by status?
\.R R Commander 

File Edit Data 

� Dataset 

R Script R Marled 

Statistics Gtaphs Models Distributions Tools Help 

Activt data set 
Contingency tables Numerical summ;i,r1es 
Means Frequency distributions ... 
Proportions Count missing observations 
Varianc� Table of statistics ... 

.,etwd("C:/U 

CTGdaca <· Nonparam!tric ttsts ► Correbtion matrix ... 

I 
read. cabl Dimensional analysis ► Correlation test ... 

header-I F,t models ► Test of normality ...

fT�� �: .. : : .... m ........... , ..... , ... --�◄ ,,._,.,,.__T_ra_n_,r_o,_m_,ow_•_rd_n_orm_•f_ity_ .. _ • ....J 

Ott• Sr.K�,u 
Vwi.t>lc, (pi<:I: one or mort) 
ltffiiuW 

.,._ 

O,t, St,tJffiCS 

V¥i,bltS (picl: Ont 0,-mor,t) 
IMl/ui':I • 

�mMlfitt by groups-I 

@Htlp 

X 

., OK X C,n<tl 

X 

X 

> numSummary(CTGdata(,"Enrollment", drop=FALSEJ,

+ .5,.75,1))

mean sd IQR 0% 25% 50% 75% 100% n 

38.375 52.8821 23.75 4 6.75 21.5 30.5 200 16 

statistics=c ("mean", "sd", "IOR", "quantiles"), quantiles=c (0,. 25, 

YEARS 
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Orientation to Rcmdr GUl's menus: Data➔summaries(l) 

• With Active Dataset, can do more specific summaries of interest:

• What if interested in how CTG studies/ enrollment numbers are by status?
\.R R Commander 

File Edit Data Statistics Gtaphs Models Distributio ns Tools Hel p 

Contingency tables ► Numerical summ;i,r1es 
� Dataset 

R Script R Marled Means 

Proportions 
► Frequency dist ri butions ... 
► Coun t missi ng observations 

Varian,� 
.,etwd("C:/U 

► Table of statistics ... 

CTGdaca <· Nonparam!tric ttsts ► 

I read. cabl Dimensional analysis ► 

header-I Fi t models ► 

f
T
���: .. :: .... m ........... , ..... , .... --�◄ ,,._,., 

Correbtion matrix ... 

Correlation test ... 
Test of normality ... 

Transform toward normality ... 

Vwi.t>lc, (pi<:I: one or mort) 
ltffiiuW • 

X 
> numSummary(CTGdata(,"Enrollment", drop=FALSEJ, statistics=c("mean", "sd", "IQR", "quantiles"), quantiles=c(0,.25,

+ .5,.75,1))

mean sd IQR 0% 25% 50% 75% 100% n 

38.375 52.8821 23.75 4 6.75 21.5 30.5 200 16 

• Overall is above, while 'group-based' below via menus for factors
Vtti•bltS (picl: Ont o,-m,or,t) 
IMl/ui':I : 

�mMlfitt by groups-I 

X 

., OK I X C,n<tl 

@"•'• ., ..... I .,/ o«. I ,c c"'"' ,+ •i>P'Y 

X 

YEARS 
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Orientation to Rcmdr GUl's menus: Data➔summaries(l) 

• With Active Dataset, can do more specific summaries of interest:

• What if interested in how CTG studies/ enrollment numbers are by status?
\.R R Commander 

file Edit Data 

� Dataset 

R Script R Marled 

Statistics Gtaphs Models Distributions Tools Help 

Contingency tables 

Means 
Proportions 
Varian,� 

Activt data set 

Numerical summ;i,r1es 
Frequency distributions ... 
Count missing observations 
Table of statistics ... 

.,etwd("C:/U 

CTGdaca <· Nonparam!tric ttsts ► Correbtion matrix ... 

I read. cabl Dimensional analysis ► Correlation test ... 
header-I F,t models ► Test of normality ... 

fT�� �: .. : : .... m ........... , ..... , ... --�◄ ,,._,.,,.__r,_,n_,_ro _,m _,ow_ar _d _n _orm_,r_ity_ .. _ • ....J 

X 

Ott• Sr.K�,u 
Vwi.t>lc, (pi<:I: one or mort) 
ltffiiuW 

.,._ 

> numSummary(CTGdata(,"Enrollment", drop=FALSEJ,

+ .S,.75,1))

mean sd IQR 0% 25% 50% 75% 100% n 

38.375 52.8821 23.75 4 6.75 21.5 30.5 200 16 

statistics=c ("mean", "sd", "IOR", "quantiles"), quantiles=c (0,. 25,

• Overall is above, while 'gro!! -based' below via menus for factor
<it R Commander 

File Edit Data Sutistics Graphs Models Distributions Tools Help 

� Oat, 'tt' � Contingfflcy tables 

R Script R MarkdJ Means 

Active data sd 
Numcnc-11 summancs .. 
Frequency distributions ... 

Pro-portions Count missing observations 
Variances Table of statistics ... 

CTGd.ata <- Non�rametric tests ► Corrtlation matrix ..• 

�read. t.abl 01mens1onal analysis ► Correfation test .. .

header•! flt models Test of normality .. .
Gdata <· Transform toward normal

i
ty ... .,.,., .. ,.v� ,,.,... /u,.,.,,.._ '••• � ,.,,i ---•�� ,,,.__.,.,._ _________ ....J 

O,t, StltlffiCS 
vtn,bltS (picl: ont o,-morlf) 
IMl/ui':I • 

�mMlfitt by groups-I 

X 

., OK I X C,n<tl 

@Htlp ., ..... I ./o«. I xc"'"' 

X 
'--R �I SurNnairits X 

DJ.ta St,tistics 
Variablts (pick one o, mo,t} 
ltttffl i,,fo\ • 

Summariu by groups. .. I 

'-A Groups 

GroupsvaNblt (pickont) 
pons« 

rt.Date 
tudy,Ocsign 

tudy.Tltlc 
jStucty.lyp� 

I ., OK 

./ OK ,C Canul 

X 

,. Apply 

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Data➔summaries(l) 

• With Active Dataset, can do more specific summaries of interest:

• What if interested in how CTG studies/ enrollment numbers are by status?
X 

\.R R Commander 

file Edit Data
Ott• Sr.K�,u > numSummary(CTGdata(,"Enrollment", drop=FALSEJ,

+ .5,.75,1))

statistics=c ("mean", "sd", "IOR", "quantiles"), quantiles=c (0,. 25, 

� Dataset 

R Script R Marled 

Statistics Gtaphs Models Distributions Tools Help 

Contingency tables 
Means 
Proportions 
Varian,� 

Activt data set 
Numerical summ;i,r1es 
Frequency distributions ... 
Count missing observations 
Table of statistics ... 

.,etwd("C:/U 

CTGdaca <· Nonparam!tric ttsts ► Correbtion matrix ... 

I read. cabl Dimensional analysis ► Correlation test ...
header-I F,t models ► Test of normality ...

fT�� �: .. : : .... m ........... , ..... , ... --�◄ ,,._,.,,.__r,_,n_,_ro _,m _,ow _ar _d _n _orm_,r_ity_ .. _ • ....J

Vwi.t>lc, (pi<:I: one or mort) 
ltffiiuW mean sd IQR 0% 25% 50% 75% 100% n 

38.375 52.8821 23.75 4 6.75 21.5 30.5 200 16 

.,._ 

• Overall is above, while 'gro!! -based' below
<it R Commander 

File Edit Data Sutistics Graphs Models Distri butions Tools Help 

� Oata Set:� 
Cont;ngfflcy tables 

R Script R MarkdJ Means 

Active data sd 
Numcnc-11 summancs .. 
Frequency distributions ... 

Pro-portions Count missing observations 
Variances Table of statistics ... 

CTGd.ata <- Non�rametric tests ► Corrtlation matrix ..• 

�
read. t.abl 01mens1onal analysis ► Correlation test .. .

header•! flt models Test of normality .. .
Gdata <· Transform toward normality ... .,.,., .. ,.v� ,,.,... /u,.,.,,.._ '••• � , .. o ---•�� ,,,.__.,.,._ _________ ....J 

Oat, StltlffiCS 

VltiabltS (picl: Ont 0,-mor,t) 
IMl/ui':I • 

�mMlfitt by groups-I 

X 

., OK I X C,n<tl 

@Help ., ..... I ./o«. I xc"'"' 

X 
'--R �I SurNnairits X 

DJ.ta Statistics 
Variablts (pick one o, mo,t} 
ltttffl i,,fo\ • 

Summariu by groups. .. I 

'-A Groups 

GroupsvaNblt (pickont} 
pons« 

rt.Date 
tudy,Oesign 

tudy.Tltlc 
jStucty.lyp� 

X 

,. Apply 

to 

..if Read Text Data From File, Clipboard, or URL 

Enter name for data set: 

Variable names in file: ■ 

Convert character variables to factors■ 

NIDDK 

X 



Orientation to Rcmdr GUl's menus: Data➔summaries(l) 

• With Active Dataset, can do more specific summaries of interest:

• What if interested in how CTG studies/ enrollment numbers are by status?
X 

\.R R Commander 

file Edit Data 
Ott• Sr.K�,u > numSummary(CTGdata(,"Enrollment", drop=FALSEJ,

+ .5,.75,1))

statistics=c ("mean", "sd", "IOR", "quantiles"), quantiles=c (0,. 25,

� Dataset 

R Script R Marled 

Statistics Gtaphs Models Distributions Tools Help 

Contingency tables 
Means 
Proportions 
Varian,� 

Activt data set 
Numerical summ;i,r1es 
Frequency distributions ... 
Count missing observations 
Table of statistics ... 

.,etwd("C:/U 

CTGdaca <· Nonparam!tric ttsts ► Correbtion matrix ... 

I read. cabl Dimensional analysis ► Correlation test ... 
header-I F,t models ► Test of normality ... 

fT�� �: .. : : .... m ........... , ..... , ... --�◄ ,,._,.,,.__r,_,n_,_ro _,m _,ow_ar _d _n _orm_,r_ity_ .. _ • ....J 

Vwi.t>lc, (pi<:I: one or mort) 
ltffiiuW mean sd IQR 0% 25% 50% 75% 100% n 

38.375 52.8821 23.75 4 6.75 21.5 30.5 200 16 

.,._ 

• Overall is above, while 'gro!! -based' below
<it R Commander 

File Edit Data Sutistics Graphs Models Distributions Tools Help 

� Oata Set:� 
Cont;ngfflcy tables 

R Script R MarkdJ Means 

Active data sd 
Numcnc-11 summancs .. 

Frequency distributions ... 

Pro-portions Count missing observations 
Variances Table of statistics ... 

CTGd.ata <- Non�rametric tests ► Corrtlation matrix ..• 
�read. t.abl 01mens1onal analysis ► Correlation test .. . 

header•! flt models Test of normality .. . 
Gdata <· Transform toward normality ... .,.,., .. ,.v� ,,.,... /u,.,.,,.._ '••• � , .. o ---•�� ,,,.__.,.,._ _________ ....J 

Oat, StltlffiCS 
VltiabltS (picl: Ont 0,-mor,t) 
IMl/ui':I • 

�mMlfitt by groups-I 

X 

., OK I X C,n<tl 

@Help ., ..... I ./o«. I xc"'"' 

X 
'--R �I SurNnairits X 

DJ.ta Statistics 

Variablts (pick one o, mo,t} 
ltttffl i,,fo\ •

Summariu by groups. .. I 

'-A Groups 

GroupsvaNblt (pickont} 
pons« 

rt.Date 
tudy,Oesign 

tudy.Tltlc 
jStucty.lyp� 

I ., OK 

./ OK ,C Canul 

X 

,. Apply 

to 

..if Read Text Data From File, C ipboard, or URL 

Enter name for data set: 

Variable names in file: ■ 

Convert character variables to factors■ 

NIDDK 

X 



• With Active Dataset, can do more specific summaries of interest:
• What if interested in how CTG studies’ enrollment numbers are by status?

•
• Overall is above, while ‘group-based’ below via menus for factors

Orientation to Rcmdr GUI’s menus: DataSummaries(1)



Orientation to Rcmdr GUl's menus: Data➔summaries(2) 
With Active Dataset, can do more customized summaries of interest: 
• What if interested in different subset of enrollment summaries by status?

• TAKE ADVANTAGE OF R Script panel content: copy, edit, select & click

numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c ("mean", "sd", "IQR", "quantiles"), quantiles=c (0,. 25,. 5,. 75, 1)) 

numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c("quantiles", "IQR" ) , quantiles=c(O, .25, .5,. 75, 1)) 

YEARS 
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Orientation to Rcmdr GUl's menus: Data➔summaries(2) 
With Active Dataset, can do more customized summaries of interest: 
• What if interested in different subset of enrollment summaries by status?

• TAKE ADVANTAGE OF R Script panel content: copy, edit, select & click

numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c ("mean", "sd", "IQR", "quantiles"), quantiles=c (0,. 25,. 5,. 75, 1)) 

numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c("quantiles", "IQR" ) , quantiles=c(O, .25, .5,. 75, 1)) 
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Orientation to Rcmdr GUl's menus: Data➔summaries(2) 
With Active Dataset, can do more customized summaries of interest: 
• What if interested in different subset of enrollment summaries by status?

• TAKE ADVANTAGE OF R Script panel content: copy, edit, select & click
numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c ("mean", "sd", "IQR", "quantiles"), quantiles=c (0,. 25,. 5,. 75, 1)) 
Can also 'highlight' 

line & use R-gui-

numSurnmary (CTGdata [,"Enrollment", drop=FALSE], groups=CTGdata$Study. Status,shortcut of 'Ctrl+R' 
statistics=c("quantiles", "IQR" ) , quantiles=c(O, .25, .5,. 75, 1)) to submit 
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Orientation to Rcmdr GUl's menus: Data➔summaries(2) 
With Active Dataset, can do more customized summaries of interest: 
• What if interested in different subset of enrollment summaries by status?

• TAKE ADVANTAGE OF R Script panel content: copy, edit, select & click
numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c ("mean", "sd", "IQR", "quantiles"), quantiles=c (0,. 25,. 5,. 75, 1)) 
Can also 'highlight' 

line & use R-gui-

numSurnmary (CTGdata [,"Enrollment", drop=FALSE], groups=CTGdata$Study. Status,shortcut of 'Ctrl+R' 
statistics=c("quantiles", "IQR" ) , quantiles=c(O, .25, .5,. 75, 1)) to submit 

So menus provide starting code, thus you can customize 1 per R function 
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Orientation to Rcmdr GUl's menus: Data➔summaries(2) 
With Active Dataset, can do more customized summaries of interest: 
• What if interested in different subset of enrollment summaries by status?

• TAKE ADVANTAGE OF R Script panel content: copy, edit, select & click
numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c ("mean", "sd", "IQR", "quantiles"), quantiles=c (0,. 25,. 5,. 75, 1)) 
Can also 'highlight' 

line & use R-gui-

numSurnmary (CTGdata [,"Enrollment", drop=FALSE], groups=CTGdata$Study. Status,shortcut of 'Ctrl+R' 
statistics=c("quantiles", "IQR" ) , quantiles=c(O, .25, .5,. 75, 1)) to submit 

So menus provide starting code, thus you can customize 1 per R function 
> numSummary(CTGdata[,T'Enrollment", drop=FALSE], giroups=CTGdata$Study.Status, statistics=c("quantiles", "IR" ),

IQR 0% 25% 50% 75% 100% E�rollment:n 

COMPkETED 25.75 5 9.75 24.0 35.50 200 14 

TERMINATED 1. 50 4 4. 7 5 5. 5 6. 25 7 21 

Same possibility to create new vars, like time since earliest CTG start 
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Orientation to Rcmdr GUl's menus: Data➔summaries(2) 
With Active Dataset, can do more customized summaries of interest: 
• What if interested in different subset of enrollment summaries by status?

• TAKE ADVANTAGE OF R Script panel content: copy, edit, select & click
numSurnmary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 

statistics=c ("mean", "sd", "IQR", "quantiles"), quantiles=c (0,. 25,. 5,. 75, 1)) 
Can also 'highlight' 

line & use R-gui-

numSurnmary (CTGdata [,"Enrollment", drop=FALSE], groups=CTGdata$Study. Status,shortcut of 'Ctrl+R' 
statistics=c("quantiles", "IQR" ) , quantiles=c(O, .25, .5,. 75, 1)) to submit 

So menus provide starting code, thus you can customize 1 per R function 
> numSummary(CTGdata[,T'Enrollment", drop=FALSE], giroups=CTGdata$Study.Status, statistics=c("quantiles", "IR" ),

IQR 0% 25% 50% 75% 100% E�rollment:n 

COMPkETED 25.75 5 9.75 24.0 35.50 200 14 

TERMINATED 1. 50 4 4. 7 5 5. 5 6. 25 7 21 

Same possibility to create new vars, like time since earliest CTG start 

I> numS�ry(�Gdata[,"DaysSinceEarliestStart", drop=FALSE], statistics=c("mean", "sd", "IOR", "quantiles"),
+ quantiles-c(0, .25, .5, .75,l)) 

mean sd IOR 0\ 25\ 50\ 75\ 100\ n NA 
1201 990.5105 1237 0 511 982 1748 3024 8 8 

> numSwcmary(CTGdata[, 11DaysS1.nceEarl1.estStart", drop=FALSE], groups=CTGdata$Study.Status, stat1.st1.cs=c("mean", 
+ "IOR", "quantiles"), quantiles=c(0, .25, .5, .75,l))

mean sd IOR 0\ 25\ 50\ 75\ 100\ DaysSinceEarliestStart:n DaysSinceEarliestStart:NA 
COMPLETED 1268.429 1049.855 1346 0 482 1235 1828 3024 7 7 

'TERMINATED 729. 000 NA 0 729 729 729 729 729 l l 

"sd", 
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Orientation to Rcmdr GUI’s menus: DataSummaries(2)

numSummary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status,
statistics=c("mean", "sd", "IQR", "quantiles"), quantiles=c(0,.25,.5,.75,1))

numSummary(CTGdata[,"Enrollment", drop=FALSE], groups=CTGdata$Study.Status, 
statistics=c("quantiles", "IQR" ), quantiles=c(0,.25,.5,.75,1))

Can also ‘highlight’ 
line & use R-gui-

shortcut of ‘Ctrl+R’ 
to submit

• With Active Dataset, can do more customized summaries of interest:
• What if interested in different subset of enrollment summaries by status?
• TAKE ADVANTAGE OF R Script panel content: copy, edit, select & click

So menus provide starting code, thus you can customize \ per R function

Same possibility to create new vars, like time since earliest CTG start



• 

Orientation to Rcmdr GUl's menus: Summaries (1) 

Don't forget that you can save your R data ➔

. . 
. . . -

File Edit Data Statistics 

Change working directory ... 

Open script file ... 

Save script ... 

Save script as ... 

Open R Markdown file .. . 

Save R Markdown file .. . 

Save R Markdown file as ... 

Save output ... 

Save output as ... 

Save R workspace ... 

Save R workspace as ... 

Exit ► 



• 

Orientation to Rcmdr GUl's menus: Summaries (1) 

Don't forget that you can save your R data ➔

. . 
. . . -

File Edit Data Statistics 

Change working directory ... 

Open script file ... 

Save script ... 

Save script as ... 

Open R Markdown file .. . 

Save R Markdown file .. . 

Save R Markdown file as ... 

Save output ... 

Save output as ... 

Save R workspace ... 

Save R workspace as ... 

Exit 

Messages 

► l
J!16) NOTE: R workspace saved to C:/Users/wilkinskj/OneDrive 

During a later Rcmdr session 

you can change your working 

directory back to current one, 

then use "Data > Load data 

set ... " menu option & its code: 
> load("ctg-studies_data-explore.Rdata")

YEARS 
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Data Statistics 

• Don't forget that you can save your R data ➔

File Edit Data Statistics 

Change working directory ... 

Open script file ... 
Save script ... 

Variables (pick one or more) 
.. 

• Note that 'Enrollment' was only numerical

variable/column in Active Dataset

Save script as ... 

Open R Markdown file .. . 
Save R Markdown file .. . 
Save R Markdown file as ... 

Save output ... 
Save output as ... 

Save R workspace ... 

Summarize by groups ... I 

Save R workspace as ... 

__ 
Exit

_o:"""":'":" __ ► l Messages 

@Help ., Reset 

J!16) NOTE: R workspace saved to C:/Users/wilkinskj/OneDrive 

During a later Rcmdr session 

you can change your working 

directory back to current one, 

then use "Data > Load data 

set ... " menu option & its code: 
> load("ctg-studies_data-explore.Rdata")
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File Edit Data Statistics Graphs 
Data Statistics 

• Don't forget that you can save your R data ➔

• Note that 'Enrollment' was only numerical

variable/column in Active Dataset

Change working directory ... 

Open script file ... 
Save script ... 
Save script as ... 

Open R Markdown file .. . 
Save R Markdown file .. . 
Save R Markdown file as ... 

Save output ... 
Save output as ... 

Variables (pick one or more). .. 
Summarize by groups ... I 

Save R workspace ... 

• To explore summaries for >1 numerical variable, "'' . l @"•'• ., ..... I ..f 0•

NH B LI tria I data for d igoxi n/ d igita I is 'DIG' treatment 1�::7

g

:OTE: R workspace saved to C:/Users/wilkinskj/OneDrive 

available in BioLINCC for educational use (like ours I) 

• We 1st show how to re-load a R workspace in Rcmdr

• As it was originally imported from SAS, has no factors

During a later Rcmdr session 

you can change your working 

directory back to current one, 

then use "Data > Load data 

set ... " menu option & its code: 
> load("ctg-studies_data-explore.Rdata")

YEARS 
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• Don’t forget that you can save your R data 
• Note that ‘Enrollment’ was only numerical

variable/column in Active Dataset
• To explore summaries for >1 numerical variable, use

NHBLI trial data for digoxin/digitalis ‘DIG’ treatment
available in BioLINCC for educational use (like ours!)

• We 1st show how to re-load a R workspace in Rcmdr
• As it was originally imported from SAS, has no factors

If we create new factors: DIG ‘group’ summaries work

Orientation to Rcmdr GUI’s menus: Summaries (1)

During a later Rcmdr session 
you can change your working 
directory back to current one, 
then use “Data > Load data 
set…” menu option & its code: 
> load("ctg-studies_data-explore.Rdata")



Orientation to Rcmdr GUl's menus: Summaries (2) 

• Best Practice: 're-load'
. Same 'File' has option to load workspace from 

prior-saved R data ➔ prior Rcmdr session IF it's in your current
working directory via menu "Data > Load data 
Set .. . " 0 pt i O n ( & its CO d e) : ;:,: • �=

m

�:· St,tirou G"phs Models o;,mbutions 

> load("DIG-trial_data-explore.Rdata") � 
Nt<W data set .. 

R Script R _ 
Merge data sets •• 

Import d"t. 

D�a in pacbg� 

Active data stt 

M111\a9e variables in active data � ► 



Orientation to Rcmdr GUl's menus: Summaries (2) 

• 1 1 • 
➔ Same 'File' has option to load workspace from 

• Best Practice: re-load prior-saved R data prior Rcmdr session IF it's in your current

• Working with 'DIG' offers more numerical

variables/columns; 1st set as Active Dataset

working directory via menu "Data > Load data 
Set ... ,, opt·1on (& ·,ts code)·.

"'RComm,ocl., 

filt Edit Oita St,tistic.s Gniph.s Modtls Oistnbution.s 

r � 0 
Nf'W data set .. 

> load("DIG-trial_data-explore.Rdata") 'ft' 

(ft R Commander 

Filt Edit D.n-• Sc.tistics Grtphs Modds Oistribu'bons Tooh Hdp 

"' 0 
New data Sort-, 
toad data set ... 

Vicw d,ttl sd Modd: r <No ldr.•t modd> 

• Then get names of variables in Active dataset ➔
� 

Scnpt RI 
Mt19t data sets ... 

norrr.all. Import dlta 1

1

norir.a11. 0.ata in p,td:a9es 
•=•,) . 

► •• daca•DIGClata) 
► • data•DIGd.ata) 

V",twd,(,t ... 

I> name3(DIGdata)

(l] "ID" "TRTMT" "AGE" "RACE" 
(11] "CREAT" "DIGOOSER" "CHFDUR" "RALES" 
[ 21 J "PULCONG" "NSYM" "HEART RTE" "DIABP" I (31] "HYPERTEN" "DIGUSE" "DIURETK" "DIURET" 

"SEX" 
"ELEVJVP" 
"SYSBP" 
"KSUPP" 

"EJF PER" "EJFMETH" "CHESTX" "BMI" 
"PEDEMA" "RESTDYS" "EXERTDYS" "ACTLIMIT" 
"FUNCTCLS" "CHFETIOL" "PREVMI" "ANGINA" 
"ACEINHIB" "NITRATES" "HYDRAL" "VASOD" 

"KLEVEL" 
"S3 ° 

"DIABETES" 
"DIGOOSE" 

lnwz$u:r. Man19' variables in active datii set ► Select active data sd,-
1)) ------

1) ) Help on aCM d.ata sd (,f availlblt) 
l

nwt.Sumrwu::y (DIGdaca ( r "WHt", dro-p-FALSt Rdrt:Sh Kt� dati set 

�C.UNr'MS,­
Subsd ,ctive dat• set­
Sort � d.tt• ste.... 
A99rit9•te variables ,n .t(t,v,e data sd.. . 

I> OlGd•t• <- Sc:l«ttow(s)from.tctM:datud-, 

I• ::udSA.S ('"C: /Unu/w:1lhnakj/OneO Remow row(s) from •«iw datl set .. 
Stack v,n,bl6 ,n •<tiv,e dm set--

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (2) 

1 1 • ➔ Same 'File' has option to load workspace from 
• Best Practice: re-load prior-saved R data prior Rcmdr session IF it's in your current 

working directory via menu "Data > Load data 
• Working with 'DIG' offers more numerical set ... " option (& its code): :·�=m�:·s,,_, G"phs Models �RObutions 

variables/columns; 1st set as Active Dataset

> load ("DIG-trial_ data-explore. Rdata") qt o N,wdatrn<. .. 

• Then get names of variables in Active dataset ➔
I> name3(DIGdata)

(l] "ID" "TRTMT" "AGE" "RACE" "SEX" "EJF PER" "EJFMETH" "CHESTX" "BMI" "KLEVEL" 
(11] "CREAT" "DIGOOSER" "CHFDUR" "RALES" "ELEVJVP" "PEDEMA" "RESTDYS" "EXERTDYS" "ACTLIMIT" "S3" 
[21] "PULCONG" "NSYM" "HEARTRTE" "DIABP" "SYSBP" "FUNCTCLS" "CHFETIOL" "PREVMI" "ANGINA" "DIABETES"

I (31] "HYPERTEN" "DIGUSE" "DIURETK" "DIURET" "KSUPP" "ACEINHIB" "NITRATES" "HYDRAL" "VASOD" "DIGOOSE" 

• Can use ''Ctrl-click'' to select a number of related vars

• We do so (next slide) to check correlations among set

(ft R Commander 

Filt Edit D.n-• Sc.tistics Grtphs Modds Oistribu'bons Tooh Hdp 

_ ii) O 
New data Sort-, View d,ttl sd Modd: r <No •dr.•t modd> 'ft toad da� set ... 

� 
Scnpt R

I 
Mt19t da� sets ... 

norrt.all. Import dlta ► •, dac.a•DIGClata) 
1

1

norir.a11. O.ata in p,td:a9es ► • data•DIGd.at.a) 
swuur� • • V",twd,t,t ... 
lnwz$u:r. Man19' variables in active datii set ► Select active data sd,-

1)) -----
nwt.Sumrwu::y (DIGdata ( r "WHt", dro-p-FALSt Rdrt:Sh Kt� dati set 

I 1) 1 Help on aCM d.ata sd (,f av•illblt) 

�C.UNr'MS,-

Subsd ,ctive dat• set.-
Sort� d.tt• ste.... 
A99rit9•te variables ,n a(t,v,e data sd.. . 

I> OlGd•t• <- Sc:l«ttow(s)fromactrvtdatud-, 
I• ::udSA.S ('"C: /Unu/w:1lhnakj/OneO Remow row(s) from active datl set .• 

Stack v,n,bl6 ,n •<tiv,e data set--

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (2) 

1 1 • ➔ Same 'File' has option to load workspace from 
• Best Practice: re-load prior-saved R data prior Rcmdr session IF it's in your current 

working directory via menu "Data > Load data 
• Working with 'DIG' offers more numerical set ... " option (& its code): :·�=m�:·s,,_, G"phs Models �RObutions 

variables/columns; 1st set as Active Dataset

> load ("DIG-trial_ data-explore. Rdata") qt o N,wdatrn<. .. 

• Then get names of variables in Active dataset ➔
I> name3(DIGdata)

(l] "ID" "TRTMT" "AGE" "RACE" "SEX" "EJF PER" "EJFMETH" "CHESTX" "BMI" "KLEVEL" 

(11] "CREAT" "DIGOOSER" "CHFDUR" "RALES" "ELEVJVP" "PEDEMA" "RESTDYS" "EXERTDYS" "ACTLIMIT" "S3" 

[21] "PULCONG" "NSYM" "HEARTRTE" "DIABP" "SYSBP" "FUNCTCLS" "CHFETIOL" "PREVMI" "ANGINA" "DIABETES" I (31] "HYPERTEN" "DIGUSE" "DIURETK" "DIURET" "KSUPP" "ACEINHIB" "NITRATES" "HYDRAL" "VASOD" "DIGOOSE" 

• Can use ''Ctrl-click'' to select a number of related vars

• We do so (next slide) to check correlations among set

DIG data can be assessed for ''regression readiness'', tool 

(ft R Commander 

Filt Edit D.n-• Sc.tistics Grtphs Modds Oistribu'bons Tooh Hdp 

_ ii) O 
New data Sort-, View d,ttl sd Modd: r <No •dr.•t modd> 'ft toad da� set ... 

� 
Scnpt R

I 
Mt19t da� sets ... 

norrt.all. Import dlta ► •, dac.a•DIGClata) 
1

1

norir.a11. O.ata in p,td:a9es ► • data•DIGd.at.a) 
swuur� • • V",twd,t,t ... 
lnwz$u:r. Man19' variables in active datii set ► Select active data sd,-

1)) -----
nwt.Sumrwu::y (DIGdata ( r "WHt", dro-p-FALSt Rdrt:Sh Kt� dati set 

I 1) 1 Help
� 

aCM cl.at
� 

sd (If availlblt) 

�C.UNr'MS,­
Subsd ,ctive dat• set.­
Sort� d.tt• ste.... 
A99rit9•te variables ,n a(t,v,e data sd.. . 

I> OlGd•t• <- Sc:l«ttow(s)fromactrvtdatud-, 
I• ::udSA.S ('"C: /Unu/w:1lhnakj/OneO Remow row(s) from active datl set .• 

Stack v,n,bl6 ,n •<tiv,e data set--

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (2) 

• 1 1 • 
➔ Same 'File' has option to load workspace from 

• Best Practice: re-load prior-saved R data prior Rcmdr session IF it's in your current

Working with 'DIG' offers more numerical 

variables/columns; 1st set as Active Dataset 

working directory via menu "Data > Load data 
• Set ... ,, opt·1on (& ·,ts code)·.

"'RComm,ocl., 

filt Edit Oita St,tistic.s Gniph.s Modtls Oistnbution.s 

r � 0 
Nf'W data set .. 

> load("DIG-trial_data-explore.Rdata") 'ft' 

• Then get names of variables in Active dataset ➔
I> name3(DIGdata)

(l] "ID" "TRTMT" "AGE" "RACE" 
(11] "CREAT" "DIGOOSER" "CHFDUR" "RALES" 
[ 21 J "PULCONG" "NSYM" "HEART RTE" "DIABP" I (31] "HYPERTEN" "DIGUSE" "DIURETK" "DIURET" 

"SEX" 
"ELEVJVP" 
"SYSBP" 
"KSUPP" 

"EJF PER" "EJFMETH" "CHESTX" "BMI" "KLEVEL" 
"PEDEMA" "RESTDYS" "EXERTDYS" "ACTLIMIT" "53" 
"FUNCTCLS" "CHFETIOL" "PREVMI" "ANGINA" "DIABETES" 
"ACEINHIB" "NITRATES" "HYDRAL" "VASOD" "DIGOOSE" 

• Can use ''Ctrl-click'' to select a number of related vars

• We do so (next slide) to check correlations among set

DIG data can be assessed for ''regression readiness'', tool 
Output 

I> sun:mary(powerTransform(cbind(BMI, CR.EAT, DIABP, Slt'SBP) - 1, dat;a=DIGdat;a, fanuly="bcnPower"))
bcnPower t;ransformat;ion t;O Mult;inormalit;y 

Est;imat;ed power, lambda 
Est; Power Rounded Pwr Wald Lwr Bnd Wald Opr Bnd 

BMI -0.6490 -0.649 -0.7583 -0.5398
!CR.EAT -1. 0379
,DIABP O. 2-261

J ,
slt'SBP �o.1�47 

-1.000 -1.1300
-0.33b 0.0921 

-o. 1�,D<I) -o. 3159

-0.9458
0.3600 

-0.0536

(ft R Commander 

Filt Edit D.n-• Sc.tistics Grtphs Modds Oistribu'bons Tooh Hdp 

"' 0 
New data Sort-, 
toad data set ... 

� 
Scnpt RI 

Mt19t data sets ... 

norrr.all. Import dlta 

•=•,) . 

Vicw d,ttl sd Modd: r <No ldr.•t modd> 

► •• daca•DIGClata) 
► • data•DIGd.ata) 

V",twd,(,t ... 

1

1

norir.a11. 0.ata in p,td:a9es 

lnwz$u:r. Man19' variables in active datii set ► Select active data sd,-
1)) ------

l

nwt.Sumrwu::y (DIGdaca ( r "WHt", dro-p-FALSt Rdrt:Sh Kt� dati set 

1) ) Help on aCM d.ata sd (,f availlblt) 

�C.UNr'MS,­
Subsd ,ctive dat• set­
Sort � d.tt• ste.... 
A99rit9•te variables ,n .t(t,v,e data sd.. . 

I> OlGd•t• <- Sc:l«ttow(s)from.tctrvtdftud-, 

I• ::udSA.S ('"C: /Unu/w:1lhnakj/OneO Remow row(s) from •«iw datl set .. 
Stack v,n,bl6 ,n •<tiv,e dm set--

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (2) 

• 1 1 • 
➔ Same 'File' has option to load workspace from 

• Best Practice: re-load prior-saved R data prior Rcmdr session IF it's in your current

• Working with 'DIG' offers more numerical

variables/columns; 1st set as Active Dataset

working directory via menu "Data > Load data 
Set ... ,, opt·1on (& ·,ts code)·.

"'RComm,ocl., 

filt Edit Oita St,tistic.s Gniph.s Modtls Oistnbution.s 

r � 0 Nf'W data set .. > load("DIG-trial_data-explore.Rdata") 'ft' 

• Then get names of variables in Active dataset ➔
I> name3(DIGdata)

(l] "ID" "TRTMT" "AGE" "RACE" 

(11] "CREAT" "DIGOOSER" "CHFDUR" "RALES" 

[ 21 J "PULCONG" "NSYM" "HEART RTE" "DIABP" I (31] "HYPERTEN" "DIGUSE" "DIURETK" "DIURET" 

"SEX" 

"ELEVJVP" 

"SYSBP" 

"KSUPP" 

"EJF PER" "EJFMETH" "CHESTX" "BMI" 

"PEDEMA" "RESTDYS" "EXERTDYS" "ACTLIMIT" 

"FUNCTCLS" "CHFETIOL" "PREVMI" "ANGINA" 

"ACEINHIB" "NITRATES" "HYDRAL" "VASOD" 

"KLEVEL" 

"S3 ° 

"DIABETES" 

"DIGOOSE" 

• Can use ''Ctrl-click'' to select a number of related vars

• We do so (next slide) to check correlations among set

DIG data can be assessed for ''regression readiness'', tool 
o��

� 
I> sun:mary(powerTransform(cbind(BMI, CR.EAT, DIABP, Slt'SBP) - 1, dat;a=DIGdat;a, fa1UJ.ly="bcnPower")) 
bcnPower t;ransformat;ion t;O Mult;inormalit;y 

Est;imat;ed power, lambda 
Est; Power Rounded Pwr Wald Lwr Bnd Wald Opr Bnd 

BMI -0.6490 -0.649 -0.7583 -0.5398
!CR.EAT -1. 0379
,DIABP O. 2-261
S'fSBP ,.o. 1"614 7 

-1.1300
0.0921

-0.3159

-0.9458
0.3600

-0.0536

Current variables (doubk--didc to o:p<tssion) 
"CEINHIB 
"CnlMIT 
"GE 

A.NGINA 

HE$1X 
Ntw vari•ble name Expression to (Ompute 
BMl_b<nP....., 8MII __._ _____ _

@Help ., Reset I .,/ OtC I ,C C,ncd ,+ Apply 

(ft R Commander 

Filt Edit D.n-• Sc.tistics Grtphs Modds Oistribu'bons Tooh Hdp 

"' 0 New data Sort-, 
toad data set ... 

� 
Scnpt RI 

Mt19t data sets ... 

norrr.all. Import dlta 

•=•,) . 

Vicw d,ttl sd Modd: r <No ldr.•t modd> 

► •• daca•DIGClata) 
► • data•DIGd.ata) 

V",twd,t,t ... 

1

1

norir.a11. O.ata in p,td:a9es 

lnwz$u:r. Man19' variables in active datii set ► Select active data sd,-
1)) ------

l
nwt.Sumrwu::y (DIGdata ( r "WHt", dro-p-FALSt Rdrt:Sh Kt� dati set 

1) ) Help on aCM d.ata let (,f availlblt) 

�caunatMS,­
Subsd ,ctive dat• set.­
Sort� d.tt• ste.... 
A99rit9•te variables ,n a(t,v,e d.ata sd.. . 

I> OlGd•t• <- Sc:l«ttow(s)fromactrvtdatud-, 
I• ::udSA.S ('"C: /Unu/w:1lhnakj/OneO Remow row(s) from active diitl sd.. .• 

Stack v,n,blts ,n •<tiv,e data set--

YEARS 

NI DD K '9so-20�" 



• Best Practice: ‘re-load’ prior-saved R data 
• Working with ‘DIG’ offers more numerical

variables/columns; 1st set as Active Dataset
• Then get names of variables in Active dataset 

• Can use “Ctrl-click” to select a number of related vars
• We do so (next slide) to check correlations among set

DIG data can be assessed for “regression readiness”, too!

Orientation to Rcmdr GUI’s menus: Summaries (2)
Same ‘File’ has option to load workspace from 
prior Rcmdr session IF it’s in your current 
working directory via menu “Data > Load data 
set…” option (& its code): 
> load("DIG-trial_data-explore.Rdata")



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander 

File Edrt Data Statist ics Graphs Models 

� Data set 
Contingency tables 

R Scnpt R Markdo Muns 

,.c0...._--;;...::J"T'� Proportions 
strl..nQ's� Vanance:s 

11.brary (Hll.1
� 

Nonparamttnc tests 
rcorr • adju.s 01me:nsional analysis
reor r. adj us 
seaeterploez.l __ Fi_t_m_od_�_s

data•OIGdata) 

Distnbutlons Toots Help 
Active data m 
Numenc,I summaries ... 
Frequenq d str,but,on� 
Count missing observations 
Table of st•tut,c> 
Coueit1lton matm: .. 
Corrdat,on test .. . 
Test of normality .. . 
Transform toward normality ... 

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander

File Edrt Data Statist ics Graphs Models 0istnbut1ons Toots Help

� Data set

R Scnpt R Markdo
... c • ...._--;;...::J"T'�

Contingency tables 

Means

Active data m
► Numenc,I summaries ...
► Frequenq d str,but,on�

Proportions ► Count missmg observations
Vanances ► Table of st•tut,c>
Nonparamttnc tests ► Coueit1lton matm: .. 

Corrdat,on test .. . 

strl..nQ's� 
library (Hmi

� rcorr.adju.s 
reor r. adj us 

seaeterploez.l __ _ 
► Test of normahty .. .

Transform toward normality ...data•OIGdata) 

,t Collti.-lon M,11/11 

v-bltl (p,(11 ,_ .. -,,J 

;A<•-
,'(1\JMII 

= CNlSlX 
frpt o# (.,1tl.Ci0fll
OP-t.,M>ftllfOCN(tf'IIOffltnl 

0 � lttlk· .. INI'
0,.,..., 
Ob_.,._•toUMi
0 CM\plft• ----

( to select non-adjac·ent vars in list, use Ctrl+click as you add ) 



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander 

File Edrt Data Statist ics Graphs Models 

� Data set 

R Scnpt R Markdo 
... c • ...._--;;...::J"T'� 

Contingency tables 
Means 
Propott,ons 
Vanance:s 
Nonparamttnc tests 

strl..nQ's� 
library (Hmi

�rcorr.adju.s 
reor r. adj us 
seaeterploez.l ____ _ 

data•OIGdata) 

,t Collti.-lon M,11/11 

v-bltl (p,(11 ,_ .. -,,J 

;A<•-
,'(1\JMII 

,AG! 

Ob_.,._•toUMi 

0 CM\plft• ----
o ,.-.-c"""""• olKelY .. IOflt 

v,,....r,-cii ....... ,..I) 
CW>OAVS 
.... ,,. 
otA™OAV """"' 
f J' 

Ob.-.i-10UH 

Q C-.irttoltwN"tlllOM 

of COl'l•bttlt 

0 Pttl'Mft p,och1<1•lflOl'!Wlt 

Q S,pu- •ri· .. d• 

Q P•rbll 

0 ,_-<Offlfll,l!I• ..,,, • ._. 
lJflMT 
..... 
.,...,,....,.... 

_r.:-::--t O �,.oMl·� 

.-rri•ClfW 

o, .... 

QnffvftlD<flltoUH 
Con,plft1 � 

Distnbutlons Toots Help 
Active data m 
Numenc,I summaries ... 
Frequenq d str,but,on� 
Count missing observations 
Table of st•tut,c> 
Coueit1lton matm: .. 

Corrdat,on test .. . 
Test of normality .. . 
Transform toward normality ... 

X 

o,-�OMWYlt.OM 

X 

( to select non-adjac·ent vars in list, use Ctrl+click as you add ) 

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander

File Edrt Data Statist ics Graphs Models Oistnbut1ons Toots Help

� Data set

R Scnpt R Markdo 
... c • ...._--;;...::J"T'� 

Contingency tables 

Means 

Active data m
► Numenc,I summaries ...
► Frequenq d str,but,on� 

Proportions ► Count missmg observations 
Vanances ► Table of st•tut,c> 
Nonparamttnc tests ► Coueit1lton matm: .. 

Corrdat,on test .. . 

strl..nQ's� 
library (Hmi

� rcorr.adju.s 
reor r. adj us 

seaeterploez.l __ _ 
► Test of normahty .. .

Transform toward normality ...data•OIGdata) 

,t Collti.-lon M,11/11 

v-bltl (p,(11 ,_ .. -•J 

;A<•-
,'(1\JMII 

,AG! 

v,,....r,-cii ....... ,..I) 

CW>OAVS 
.... ,,. 
otA™OAV """"' 
f J' 

of COl'l•bttlt 

0 Pttl'Mft p,och1<1•lflOl'!Wlt 

Q S,pu- •ri· .. d• 

0 P•rbll 

lJflMT 

..... 
.,...,,....,.... 

�-� O�,.oMl·� 
.-rri•ClfW 

o, .... 

QnffvftlD<flltoUH 

Con,plft1 � 

o,-�OMWYlt.OM 

( to select non-adjac·ent vars in list, use Ctrl+click as you add ) 

[ for illustration we select pairwise-complete Pearson's with p-values ] 

2 

� /97 

Pairwise 

BMI 

BMI 

two-sided 

CREAT 

0.2255 

CREAT 0.2255 

DIABP 0.9656 0 

SYSBP 0.709 

Adju 

p-val 1

DIA



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander 

File Edrt Data Statistics Graphs Models Oistnbut1ons Toots Help 
Active data m

n· Data set 'ft: Contingency tables ► Numenc,I summaries ...
R Script R Markdo Means ► Frequenq d str,but,on�

... c • ...._--;;...::J"T'� Proportions ► Count missing observations
strl..nQ's� Vanances ► Table of st•tut,c>

11.brary (Hllij Nonparamttnc tests ► Coueit1lton matm: ..
rcorr • adju.s 

J 01me:nsional analysis Corrdat,on test .. . 
reorr • adjus

_J fit mod�s ► Test of normahty .. .
seaeterplotl'1..., __ 

data•OIGdat&) Transform toward normality ... 

,t Collti.-lon M,11/11 

v-bltl (p,(11 ,_ .. -•J 
;A<•-
,'(1\JMII 

,AG! 

v,,....r,-cii ....... ,..I) 
CW>OAVS 
.... ,,. 
otA™OAV """"' 
f J' 

of COl'l•bttlt 
0 Pttl'Mft p,och1<1•lflOl'!Wlt 
Q S,pu- •ri· .. d• 

0 P•rbll 

lJflMT 
..... 

.-rri•ClfW 

o, .... 

QnffvftlD<flltoUH 
Con,plft1 � 

o,-�OMWYlt.OM 

( to select non-adjac·ent vars in list, use Ctrl+click as you add ) 

[ for illustration we select pairwise-complete Pearson's with p-values ] 

> 

rcorr.adjust(DIGdata[,c("BMI","CREAT","DIABP"," 

YSBP")], type="pearson", 

use="pairwise.complete") 

Pearson correlations: 

BMI CREAT DIABP 

BMI 1.0000 -0.0147 0.0005

CREAT -0.0147 1.0000 -0.0130

DIABP 0.0005 -0.0130 1.0000

SYSBP 0.0045 -0.0093 0.0101

Number of observations: 

BMI CREAT DIABP SYSBP 

BMI 6799 6799 6794 6796 

CREAT 6799 6800 6795 6797 

DIABP 6794 6795 6795 6792 

SYSBP 6796 6797 6792 6797 

SYSBP 

0.0045 

-0.0093

0.0101

1.0000

Pairwise two-sided p-values:

BMI CREAT DIABP SYSBP 

BMI 0.2255 0.9656 0.7096 

CREAT 0.2255 0.2842 0.4424 

DIABP 0.9656 0.2842 0.4053 

SYSBP 0.7096 0.4424 0.4053 

Adjusted p-values (Holm's method)

BMI CREAT DIABP SYSBP 

BMI 1 1 1 

CREAT 1 

DIABP 1 

SYSBP 1 

1 

1 

1 

1 

1 

1 

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander 

File Edrt Data Statist ics Graphs Models Oistnbut1ons Toots Help 
Active data m n· Data set 'ft: Contingency tables ► Numenc,I summaries ...

R Script R Markdo Means ► Frequenq d str,but,on�

... c • ...._--;;...::J"T'� Proportions ► Count missing observations
strl..nQ's� Vanances ► Table of st•tut,c>

11.brary (Hllij Nonparamttnc tests ► Coueit1lton matm: ..
rcorr • adju.s J 01me:nsional analysis Corrdat,on test .. . 
reorr • adjus_J fit mod�s ► Test of normahty .. . 
seaeterplotl'1..., __ 

data•OIGdat&) Transform toward normality ... 

,t Collti.-lon M,11/11 
v-bltl (p,(11 ,_ .. -•J
;A<•-
,'(1\JMII 

,AG! 

v,,....r,-cii ....... ,..I)
CW>OAVS .... ,,. 
otA™OAV """"' 
f J' 

of COl'l•bttlt 

0 Pttl'Mft p,och1<1•lflOl'!Wlt 

Q S,pu- •ri· .. d• 

0 P•rbll 

.-rri•ClfW 
o, .... 

QnffvftlD<flltoUH 
Con,plft1 � 

o,-�OMWYlt.OM 

( to select non-adjac·ent vars in list, use Ctrl+click as you add ) 

[ for illustration we select pairwise-complete Pearson's with p-values ] 

> 

rcorr.adjust(DIGdata[,c("BMI","CREAT","DIABP"," 

YSBP")], type="pearson", 

use="pairwise.complete") 

Pearson correlations: 

BMI CREAT DIABP 

BMI 1.0000 -0.0147 0.0005

CREAT -0.0147 1.0000 -0.0130

DIABP 0.0005 -0.0130 1.0000

SYSBP 0.0045 -0.0093 0.0101

Number of observations: 

BMI CREAT DIABP SYSBP 

BMI 6799 6799 6794 6796 

CREAT 6799 6800 6795 6797 

DIABP 6794 6795 6795 6792 

SYSBP 6796 6797 6792 6797 

SYSBP 

0.0045 

-0.0093

0.0101

1.0000

R CorttllliGnftil 

V,IWlbtfl C,t<lt two)
H[SfX 
"''""' 
HfOIOL 

""'' 
RiV 

l)11t of Cotrtlmotl AlttrlWCM �tltid
0 Purson p,odu<t•MOmtf'lt O lwo•1tdtd 
0 S,.,rm,n rt,t1fc:Ofdtf Q Cor1111Mion • 0 
OKtNMIFtt-"'1 Q Cor,dMIOft>O 

Pairwise 

BMI 

BMI 

two-sided 

CREAT 

0.2255 

CREAT 0.2255 

DIABP 0.9656 0.2842 

p-values:

DIABP SYSBP 

0.9656 0.7096 

0.2842 0.4424 

0.4053 

SYSBP 0.7096 0.4424 0.4053 

Adjusted p-values (Holm's method)

BMI CREAT DIABP SYSBP 

BMI 1 1 1 

CREAT 1 

DIABP 1 

SYSBP 1 
X 

1 

1 

1 

1 

1 

1 

YEARS 

@Htlp ., Amt [ ./ oQ X CM1ul ,. ... � NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander 

File Edrt Data Statist ics Graphs Models Oistnbut1ons Toots Help 
Active data m n· Data set 'ft: Contingency tables ► Numenc,I summaries ...

R Script R Markdo Means ► Frequenq d str,but,on�

... c • ...._--;;...::J"T'� Proportions ► Count missing observations
strl..nQ's� Vanances ► Table of st•tut,c>

11.brary (Hllij Nonparamttnc tests ► Coueit1lton matm: ..
rcorr • adju.s J 01me:nsional analysis Corrdat,on test .. .
reorr • adjus_J fit mod�s ► Test of normahty .. .
seaeterplotl'1..., __ 

data•OIGdat&) Transform toward normality ...

,t Collti.-lon M,11/11 

v-bltl (p,(11 ,_ .. -•J 

;A<•-
,'(1\JMII 

,AG! 

v,,....r,-cii ....... ,..I) 
CW>OAVS .... ,,. 
otA™OAV """"' 
f J' 

of COl'l•bttlt 

0 Pttl'Mft p,och1<1•lflOl'!Wlt 

Q S,pu- •ri· .. d• 

0 P•rbll 

.-rri•ClfW 

o, .... 

QnffvftlD<flltoUH 
Con,plft1 � 

o,-�OMWYlt.OM 

( to select non-adjac·ent vars in list, use Ctrl+click as you add ) 

[ for illustration we select pairwise-complete Pearson's with p-values ] 

> 

rcorr.adjust(DIGdata[,c("BMI","CREAT","DIABP"," 

YSBP")], type="pearson", 

use="pairwise.complete") 

Pearson correlations: 

BMI CREAT DIABP 

BMI 1.0000 -0.0147 0.0005

CREAT -0.0147 1.0000 -0.0130

DIABP 0.0005 -0.0130 1.0000

SYSBP 0.0045 -0.0093 0.0101

Number of observations: 

BMI CREAT DIABP SYSBP 

BMI 6799 6799 6794 6796 

CREAT 6799 6800 6795 6797 

DIABP 6794 6795 6795 6792 

SYSBP 6796 6797 6792 6797 

SYSBP 

0.0045 

-0.0093

0.0101

1.0000

R CorttllliGnftil 

l)11t of Cotrtlmotl AlttrlWCM �tltid 

0 Purson p,odu<t•MOmtf'lt O lwo•1tdtd 
0 S,.,rm,n rt,t1fc:Ofdtf O CorrtlMIOn • 0 

0 Ktl'ICMIFt t-"'I O CorrdMIOl'I > 0 

Pairwise two-sided p-values:

BMI CREAT DIABP SYSBP 

BMI 0.2255 0.9656 0.7096 

CREAT 0.2255 0.2842 0.4424 

DIABP 0.9656 0.2842 0.4053 

SYSBP 0.7096 0.4424 0.4053 

Adjusted p-values (Holm's method)

BMI CREAT DIABP SYSBP 

BMI 1 1 1 

CREAT 1 

DIABP 1 

SYSBP 1 
X 

1 

1 

1 

1 

1 

1 

YEARS 

NI DD K '9so-20�" 



Orientation to Rcmdr GUl's menus: Summaries (3) 
Change Active Dataset, to DIG trial data (by im ort of NHLBl

1

s SAS file) 
'bivariate' data summaries under menus now available for >1 continuous vars 

--JI R Commander 

File Edrt Data Statist ics Graphs Models Oistnbut1ons Toots Help 
Active data m n· Data set 'ft: Contingency tables ► Numenc,I summaries ...

R Script R Markdo Means ► Frequenq d str,but,on�

... c • ...._--;;...::J"T'� Proportions ► Count missing observations
strl..nQ's� Vanances ► Table of st•tut,c>

11.brary (Hllij Nonparamttnc tests ► Coueit1lton matm: ..
rcorr • adju.s J 01me:nsional analysis Corrdat,on test .. . 
reorr • adjus_J fit mod�s ► Test of normahty .. .
seaeterplotl'1..., __ 

data•OIGdat&) Transform toward normality ...

,t Collti.-lon M,11/11 

v-bltl (p,(11 ,_ .. -•J 

;A<•-
,'(1\JMII 

,AG! 

v,,....r,-cii ....... ,..I) 
CW>OAVS .... ,,. 
otA™OAV """"' 
f J' 

of COl'l•bttlt 

0 Pttl'Mft p,och1<1•lflOl'!Wlt 

Q S,pu- •ri· .. d• 

0 P•rbll 

.-rri•ClfW 

o, .... 

QnffvftlD<flltoUH 
Con,plft1 � 

o,-�OMWYlt.OM 

( to select non-adjac·ent vars in list, use Ctrl+click as you add ) 

[ for illustration we select pairwise-complete Pearson's with p-values ] 

> 

rcorr.adjust(DIGdata[,c("BMI","CREAT","DIABP"," 

YSBP")], type="pearson", 

use="pairwise.complete") 

Pearson correlations: 

BMI CREAT DIABP 

BMI 1.0000 -0.0147 0.0005

CREAT -0.0147 1.0000 -0.0130

DIABP 0.0005 -0.0130 1.0000

SYSBP 0.0045 -0.0093 0.0101

Number of observations: 

BMI CREAT DIABP SYSBP 

BMI 6799 6799 6794 6796 

CREAT 6799 6800 6795 6797 

DIABP 6794 6795 6795 6792 

SYSBP 6796 6797 6792 6797 

SYSBP 

0.0045 

-0.0093

0.0101

1.0000

R CorttllliGnftil 

l)11t of Cotrtlmotl AlttrlWCM �tltid 

0 Purson p,odu<t•MOmtf'lt O lwo•1tdtd 
0 S,.,rm,n rt,t1fc:Ofdtf O CorrtlMIOn • 0 

0 Ktl'ICMIFt t-"'I O CorrdMIOl'I > 0 

Pairwise two-sided p-values:

BMI CREAT DIABP SYSBP 

BMI 0.2255 0.9656 0.7096 

CREAT 0.2255 0.2842 0.4424 

DIABP 0.9656 0.2842 0.4053 

SYSBP 0.7096 0.4424 0.4053 

Adjusted p-values (Holm's method)

BMI CREAT DIABP SYSBP 

BMI 1 1 1 

CREAT 1 

DIABP 1 

SYSBP 1 
X 

1 

1 

1 

1 

1 

1 

�T_bcnPower, alternative•"two.sided" 

rrelat1on 

f.ze-�i ��\ 

� YEARS 

NI DD K '9so-20�" 



• Change Active Dataset, to DIG trial data (by import of NHLBI’s SAS file)
‘bivariate’ data summaries under menus now available for >1 continuous vars

( to select non-adjacent vars in list, use Ctrl+click as you add )
[ for illustration we select pairwise-complete Pearson’s with p-values ]

Orientation to Rcmdr GUI’s menus: Summaries (3)

> 
rcorr.adjust(DIGdata[,c("BMI","CREAT","DIABP","
SYSBP")], type="pearson", 
use="pairwise.complete")

 Pearson correlations:
   BMI   CREAT   DIABP   SYSBP

BMI    1.0000 -0.0147  0.0005  0.0045
CREAT -0.0147  1.0000 -0.0130 -0.0093
DIABP  0.0005 -0.0130  1.0000  0.0101
SYSBP  0.0045 -0.0093  0.0101  1.0000

 Number of observations: 
       BMI CREAT DIABP SYSBP
BMI   6799  6799  6794  6796
CREAT 6799  6800  6795  6797
DIABP 6794  6795  6795  6792
SYSBP 6796  6797  6792  6797

 Pairwise two-sided p-values:
      BMI    CREAT  DIABP  SYSBP 
BMI      0.2255 0.9656 0.7096
CREAT 0.2255        0.2842 0.4424
DIABP 0.9656 0.2842    0.4053
SYSBP 0.7096 0.4424 0.4053  

 Adjusted p-values (Holm's method)
      BMI CREAT DIABP SYSBP
BMI        1     1     1 
CREAT  1      1     1 
DIABP  1   1    1 
SYSBP  1   1     1



• 

Orientation to Rcmdr GUl's menus: Graphics (1) 

For DIG 
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Orientation to Rcmdr GUl's menus: Graphics (1) 

• For DIG Active Dataset, let's go beyond bar plots & single scatterplots

"In order to create an anonymous dataset that protects 

patient confidentiality, most variables have been permuted 

over the set of patients within treatment group. Therefore, 

this dataset can reproduce the results of the NEJM 

paper; however, it would be inappropriate to use this 

dataset for other research or publication purposes. 

Multidimensional relationships, not included in the 

NEJM, may not have been preserved during the 

permutation process." -THUS, lack of BPs' correlation 
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Orientation to Rcmdr GUI’s menus: Graphics (1)
• For DIG Active Dataset, let’s go beyond bar plots & single scatterplots

“In order to create an anonymous dataset that protects 
patient confidentiality, most variables have been permuted
over the set of patients within treatment group. Therefore, 
this dataset can reproduce the results of the NEJM 
paper; however, it would be inappropriate to use this 
dataset for other research or publication purposes. 
Multidimensional relationships, not included in the
NEJM, may not have been preserved during the 
permutation process.” –THUS, lack of BPs’ correlation



Orientation to Rcmdr GUI’s menus: Graphics (3)
• ‘group-based’ scatterplot matrices post-normality transformations

Does each distribution, by 
treatment color, tend 
toward one that’s more 
unimodal & symmetric?

See the ‘synthetic 
trial’ data for added 
illustration of 
correlation & graphs 



To exit, use File > Exit > options or ‘X’ on Rcmdr window
[ save script/workspace/output beforehand though ]

To summarize: couldn’t you now note that you’ve got traction on 1-2 items below?
You could, now if not after engaging hands-on per this webinar & others (listed online)
R is For All, Part 1: R Commander to lower learning curves
• Loading Rcmdr, Orientation to its GUI Window’s panels/menus
• Importing Data, setting an Active Dataset, single dataframe curation
• Navigating menus & generating re-usable code: exploring Active data

• Take Home Objective: For beginners, know how to load R Commander,
import data, and navigate the GUI.

From Rcmdr Orientation to Usable Data Steps:
OVERALL Take Home Objectives

https://bioinformatics.ccr.cancer.gov/btep/classes/principles-of-data-collection-and-management
https://bioinformatics.ccr.cancer.gov/btep/classes/principles-of-data-collection-and-management


Other helpful 
resources /links 

within NIH SharePoint:

Questions? Comments? Other 
feedback or concerns?
[ some R originators’ s original take homes below ]

“Data are meant to be used by All so, clearly, a freely 
available & open-source software like R is for All.”

“R changed my opinion of humanity to some extent, to see 
how people are really willing to freely give of themselves and 
produce something larger than themselves without any 
thought of personal glory.” – Ross Ihaka [ History of Data Science ]

“We wanted users to be able to begin in an interactive environment, 
where they did not consciously think of themselves as programming. 
Then as their needs became clearer and their sophistication 
increased, they should be able to slide gradually into programming, 
when language and system aspects would become more important.” 
– Ross Ihaka [ Medium ]

“The large and active community is a major strength, 
contributing to its vast library of packages and ongoing 
development.” – Robert Gentleman & Ross Ihaka [ R Bloggers ]

“We have named our language R—
in part to acknowledge the 
influence of [ Bell Lab’s John 
Chambers-originated language] S 
and in part to celebrated our own 
efforts.” – Robert Gentleman & 
Ross Ihaka [ R Documentation ]

“Although it was originally 
intended for use in basic statistics 
classes, the current capabilities of 
the R Commander…extend well 
beyond basic statistics.” – John D. 
Fox [ R Commander Textbook Preface ]

“[Rcmdr is designed for] providing 
access to R statistical software through 
familiar menus and dialog boxes instead 
of by typing potentially arcane 
commands.” – John D. Fox [ R Commander
Textbook Preface ]



Other helpful 
resources 

/links within 
NIH SharePoint:

Additional Slides Follow for more details to 
consider when you try Rcmdr on yr own time…



• 

Nuance with Rcmdr GUl's menu options: Data import (+1) 

WHEN im ortin data, issues in some formats [AswE sHoww1rH o R1G1NAL.csvF1LE}

•

• 

Excel-able files: .csv {IF NO CELLS or ENTRIES HAVE COMMAS NOT INSIDE '"'s

OR USE .xlsx (or character-delimited .txt files-IF NO cELLs oR ENTRIES HAVE coMMAs) 

FEW ISSUES using analytic platforms' files: sAs/ stata/sPss

\.ft' R Commander 

File Edit Data Statistics Graphs Models 

DJ--New data set...
Load data set. .. 

Distributions Tools Help

l set � View data

R Script R Merge data sets ... 
================:::::r-

'--
-----

• Again, 'file'/'worksheet' becomes a R 'data. frame'
Active data set 
Manage variables in active data set 

from text file, clip 
from SPSS data SE 
from SAS xport fil 
from SAS b7dat fi 
from Minitab dat, 
from STATA data 
from Excel file ... Designating ingest settings, becom.es Active data 

qr Read Text Data From file, Clipboard, or URL 

Enter name for data set: CTGdatal 
Variable names in file: II

Convert character variables to factors II
Missing data indicator: 
Location of Data File 
0 local file system 
Q Clipboard 

0 Internet URL 
Field Separator 
0 White space O Commas [,) 

0 Semicolons�) 0 Tabs 

0 Other Specify: 
Decimal-Point Character 
0 Period[.) 
0 Comma[,) 

@Help .,/ OK )C Cancel 

X (R' Read Text Data From File, Clipboard, or URL 

Ente.r name for data set 
Variable names in file: 

Dataset 

"

Convert character variables to factors II 
Missing data indicator: 
Location of Data File 
0 local file system 
0 Clipboard 
0 Internet URL 
Field Separator 
0 White space O Commas LI
0 Semicolons �) 0 Tabs 
0 Other Specify: 
Decimal-Point Character 
0 Period(.) 
0 Comma(,) 

@Help 

NA 

,C Cancel 

X � R Commander 

File Edit 

R Da

R Script R 

Data Statistics Graphs 

New data set ... 

Load data set ... 

Merge data sets ... 

Models Distributions 

7set 

Tools Help 

View data set 

------------------,�============= 

Import data ► 

Data in packages 

Active data set 

Manage variables in active data set 

► 

► 

► 

from text file, clipboard, or URL. .. 

from SPSS data set. .. 

from SAS xport file .. . 

from SAS b7dat file .. . 

from Minitab data set ... 

from STATA data set... 

from Excel file ... 





.



• WHEN importing data, issues in some formats
• Excel-able files: .csv (IF NO CELLS or ENTRIES HAVE COMMAS NOT INSIDE “”s

OR USE .xlsx (or character-delimited .txt files—IF NO CELLS OR ENTRIES HAVE COMMAS )

• FEW ISSUES using analytic platforms’ files: SAS / Stata /SPSS

• Again, ‘file’/‘worksheet’ becomes a R ‘data.frame’

• Designating ingest settings, becomes Active data

Nuance with Rcmdr GUI’s menu options: Data import (+1)
[ AS WE SHOW WITH ORIGINAL .CSV FILE }

















• Save as Excel (.xlsx) format, THEN use Rcmdr’s capacity to read columns

• Importing using Excel format:

Nuance with Rcmdr GUI’s menu options: Data import (+3)

And the new Rcmdr-generated code of ‘readXL’ is echoed 













• With data now imported, we can add columns to data frame via menu
• Possible as we have Active dataset in Blue

Re-using variables in a different form (‘factors’), via (sub)menu:
• After NEW column add, ‘refresh’ the Active dataset to use it, as below

• And note new variable available: see correl. dialog

Additional options in Rcmdr GUI’s menus: Data (+1)

Re-using & customizing code /









• With data now imported, we view categorical vars via bar chart
• Possible with Active dataset in Blue; may be issues with string data as below

• Replace with Acronyms
• Use alt. string labels

Occasional issues in Rcmdr GUI’s menus: Data (+2)















• With data now imported, we view the data frame via menu or button
• Possible as we have Active dataset in Blue

Re-using menu option & selecting a smaller column subset: still errors
• Bottom Line: if you encounter errors, it may be data

• Can create subset,
• then ‘refresh’ the Active dataset (@ right)
• then try again… let us know if you get it working!

Occasional issues in Rcmdr GUI’s menus: Data (+3)



• Importing using SAS format:

Non-Excel import via Rcmdr GUI’s menus: Data (+2)

And the new Rcmdr-generated code of ‘readXL’ is echoed 













Scatterplot matrices:  ‘group-based’ graph menu now offers factors

RCommander: how ‘default’ steps to analysis  (GUI-
generated code) can be customized to your use



Per the Tcler's Wiki:
• What is Tcl?
• Tcl is a simple-to-learn yet very powerful programming language.

Its syntax is described in just a dozen rules, but it has all the
features needed to rapidly create useful programs in almost any
field of application - on a wide variety of international platforms.
See more about Tcl at What is Tcl

• What is Tk?
• Tk is a graphical toolkit for Tcl. It allows you to develop graphical

applications that run on Windows, Linux, MacOS X and many
other platforms. And not just from Tcl - Tk can be used from
many languages including C, Ruby, Perl, Python and Lua. See
more about Tk at What is Tk

For the morbidly curious about Rcmdr GUI: relies on tcl/tk

https://wiki.tcl-lang.org/
https://wiki.tcl-lang.org/page/What+is+Tcl
https://wiki.tcl-lang.org/page/What+is+Tk




We link here out to another document in resource folder
• Synthetic Trial example of Brown Fat Activation
• What is effect of days of treatment, standard v. new?

• Note that these are completely synthetic data curated for illustration
• Posited ‘trial’: a convenience sample of college students enrolled in Summer
• For sake of participant convenience, each student chose length of time at NIH

• This set length of Assigned Treatment (in days within Metabolic Chamber unit at Clinical Ctr.)
• Some opted for ‘long weekend’ stay while others’ schedules accommodated half a month or so
• At time of discharge, each student is ‘challenged’ (cold exposure): measure brown fat activity
• Key comparison: does an intramural-developed novel agent elicit greater brown fat activation per 

specialized time-denominated imaging than ‘standard’ cold exposure re-used per prior trial
• Thankfully, each arm exhibited comparable exposure: ‘DaysOfAssignedTreatment’!

In additional materials, you can follow along in seeing arm-based outcome regression
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