Bioinformatics Training and Education Program

BTEP Question Forum

BTEP maintains several Question and Answer Forums of interest to the NCI/CCR community.
Currently, there are forums on these topics listed below:

If you wish to ask a question go to the Ask Question Page and submit your question.

 Back to Questions

Error in library(DESeq)

I am running the command line shown in chapter XXII (cat simple_counts.txt | Rscript deseq1.r 3x3 > result.txt)

This returned an error message "dyld: Library not loaded: @rpath/libreadline.6.2.dylib

  Referenced from: /Users/yangc2/miniconda3/envs/bioinfo/lib/R/lib/libR.dylib

  Reason: image not found

Abort trap: 6".

I also tried the other Rscripts deseq2.r and edger.r. But all gave a similar error message and no correct output file. Is there a way to resolve this?

I am running this in Ubuntu/PC.


Kudos to Amy's feedback. It turned out to be some setting issue with the r software package. This issue is resolved by re-running the codes as follow:

conda install r

conda install -y bioconductor-deseq bioconductor-deseq2 bioconductor-edger r-gplots


1 Answer:

Hi, Just wanted to note that this question has been answered and solved by reinstalling the R software.

Answered on May 1st, 2020 by